Download it now!
Bug 96012 - Type Formatting - unable to navigate Column Information editing interface
Summary: Type Formatting - unable to navigate Column Information editing interface
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.1 target:5.0.5
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-11-23 16:02 UTC by shortavephotography
Modified: 2016-10-25 19:12 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Selecting second from the top title, column info grayed out (27.53 KB, image/png)
2015-11-23 16:02 UTC, shortavephotography
Details
Sample .tsv file for testing (5.39 KB, text/tab-separated-values)
2015-11-23 18:43 UTC, shortavephotography
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shortavephotography 2015-11-23 16:02:54 UTC
Created attachment 120743 [details]
Selecting second from the top title, column info grayed out

When copying and pasting information from a .TSV file in Base in these steps:

copy entire .TSV file>click on Tables> Edit Menu paste>Copy Table Window (options are definition and data and use first lines as columns> Next> Apply All columns> next> Type Formatting. 

The only way to input information, if you are working down your list of titles, is to select the next item down and then go back and click the previous title. Otherwise, the title's column information section will be grayed out and inaccessible. This works on an individual title by title basis but lets say you need to go back and edit the one at the top. The only way to 'reset' the grayed out column information section for that title is to click the "back' button to go back to the previous screen, and then click next to return to the type formatting window. from there you can then access the column information fields.
Comment 1 Alex Thurgood 2015-11-23 17:01:41 UTC
@shortavephotography : please post a sampel TSV file and sample ODB file so that we can try and reproduce - I'm a bit lost at the moment when you talk of titles,
Comment 2 Alex Thurgood 2015-11-23 17:02:14 UTC
I assume you mean field names ?
Comment 3 shortavephotography 2015-11-23 18:43:25 UTC
Created attachment 120744 [details]
Sample .tsv file for testing
Comment 4 Robert Großkopf 2015-11-27 18:49:49 UTC
Problem not only on screenshot seems to be:
There are chosen two fields at one time.
I got this error on LO 4.4.7.1, OpenSUSE 13.2 64bit rpm Linux.

If I chose the second field the former chosen field will also be marked.

Works right in LO 4.3.7., fails first here with LO 4.4.0.3. So I set the version to LO 4.4.0.3
Comment 5 Julien Nabet 2015-12-02 19:12:51 UTC
I'm not sure to understand the initial description.

On pc Debian x86-64 with master sources updated today, I noticed that when clicking on a field it's ok but if I click on another, the first one is still selected.
In fact, you must click again on a selected field to unselect it (like a switch on/off button).
Comment 6 Julien Nabet 2015-12-02 20:19:07 UTC
I gave a try with https://gerrit.libreoffice.org/#/c/20360/
With this patch, I disabled multiselection.
If gerrit is ok and no one complains, I'll push it on master and wait your feedback from a daily build test.
Comment 7 Commit Notification 2015-12-02 20:48:59 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=103cd686de34b668a838c459f3d827c02e704656

tdf#96012: Type formatting in Base shouldn't be multiselect

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2015-12-02 20:49:25 UTC
Since gerrit indicated the patch was ok, I pushed it on master.
After 24-48hours, it'll be on daily builds.
Comment 9 Lionel Elie Mamane 2015-12-03 03:31:37 UTC
This was hard to reproduce, because the instructions did not mention that one had to copy the .tsv file from *Calc*. I tried from emacs, and then nothing happened.

Julien, multiselection was enabled in older versions, so while your patch works around the problem, I hope we can have a better fix, namely that the multiselection works with the usual shift/ctrl thing, not by simply clicking. Not sure how to achieve that, though.

Szymon, you did the .ui conversion that (my best guess) introduced this regression, do you know how to achieve the above?
Comment 10 Lionel Elie Mamane 2015-12-03 04:06:21 UTC
(In reply to shortavephotography from comment #0)

> (...). This works on an individual title by title
> basis but lets say you need to go back and edit the one at the top. The only
> way to 'reset' the grayed out column information section for that title is
> to click the "back' button to go back to the previous screen, and then click
> next to return to the type formatting window. from there you can then access
> the column information fields.

Without taking away from the fact that this is a bug, for the first row, you can:

1) click on any row that is currently selected to unselect it
2) click on the first row

or:

1) click on the first row to select it
2) click on any row (except the first) that is currently selected to unselect it
Comment 11 Commit Notification 2015-12-03 04:13:01 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2d479854a9182234a378166900240aee7e1c79b

tdf#96012 enable simple mode for the multilistbox

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-12-03 04:13:05 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de9d0e797903e7ecc19be2b05c7e89d5936ae02d

Revert "tdf#96012: Type formatting in Base shouldn't be multiselect"

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-12-03 20:08:03 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46f1a9e00d44eba9837f1aecb6c183580541a014&h=libreoffice-5-1

tdf#96012 enable simple mode for the multilistbox

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-12-14 09:11:12 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4a3565255c3a766cb35e7efd93dfc24795c7606&h=libreoffice-5-0

tdf#96012 enable simple mode for the multilistbox

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Robinson Tryon (qubit) 2015-12-17 10:35:19 UTC Comment hidden (obsolete)