Bug Hunting Session
Bug 96015 - Add links to wiki, askbot, TDF, portals in Help menu
Summary: Add links to wiki, askbot, TDF, portals in Help menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: medium trivial
Assignee: Olivier Hallot
URL:
Whiteboard: target:5.3.0
Keywords: topicUI
: 62005 106874 (view as bug list)
Depends on:
Blocks: Help-Menu
  Show dependency treegraph
 
Reported: 2015-11-23 17:33 UTC by Olivier Hallot
Modified: 2017-06-14 16:04 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
the current Send Feedback landing page (131.36 KB, image/png)
2016-07-05 20:08 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2015-11-23 17:33:48 UTC
As suggested by user, the help menu should contain URL (sub)entries for 

TDF wiki
Localized Askbot (or english Askbot fallback)
Localized LibreOffice portal (or english fallback)
Official TDF blog
Localized mailing lists page
(localized) Donation page
Bugzilla (cf tdf#35855)

Very easy to implement
Comment 1 A (Andy) 2015-11-23 20:19:46 UTC
Where in the help menu would you like to have them?
Comment 2 Olivier Hallot 2015-11-23 20:39:55 UTC
What about:

Help (F1)
What is this?
-----
Questions & Answers (linked to askbot)
Mailing list (linked to localized ML's page)
Official LibreOffice blog (localized blog under TDF)
Feedback (bugzilla)
License information (as it is)
Check for updates (as it is)
----
Donate to LibreOffice (to highlight donation)
-----
About LibreOffice
Comment 3 A (Andy) 2015-11-23 21:02:22 UTC
Thank you very much for your very fast reply.

"Questions & Answers" and "Donate to LibreOffice" sound like a very good proposal.
Regarding "Mailing list" and "Official LibreOffice blog" I have no opinion yet.
Comment 4 Olivier Hallot 2016-07-04 19:10:35 UTC
I'll add to the Help entries in LibreOffice

"Download Offiline Help Content"
"Download Getting Started Guide"
Comment 5 Heiko Tietze 2016-07-04 21:12:28 UTC
(In reply to Olivier Hallot from comment #2)
> What about:
> 
> Help (F1)
> What is this?
> -----
> Questions & Answers (linked to askbot)
> Mailing list (linked to localized ML's page)
Which one do you have in mind?

> Official LibreOffice blog (localized blog under TDF)
> Feedback (bugzilla)
Sounds weird to go to the bugtracker when you just want to praise the developers. 

> License information (as it is)
> Check for updates (as it is)
> ----
> Donate to LibreOffice (to highlight donation)
> -----
> About LibreOffice

+ Fanship (Facebook, G+, Twitter)

We should be careful with the help menu however and not overflood it with links. Adding NEEDSUXEVAL for more ideas.

Definitely an EASYHACK. The localization might be the only hurdle. Setting NEEDINFO and NEEDSDEVEVAL.
Comment 6 jani 2016-07-05 06:40:04 UTC
please remember to use the "topic<foo>" keywords, we use that to sort easyhacks for people.
Comment 7 Olivier Hallot 2016-07-05 19:15:14 UTC
OK. After some discussion with the staff here is a suggestion

Help
   LibreOffice Help (F1)
   What is this?
   --------------------------
   Download Offine Help (*)
   Download The Book of LibreOffice [link to latest LO Getting Started book in PDF] (*)
   --------------------------
   Questions & Answers [link to askbot.libreoffice.org] (*)
   Get More Support [link to support webpage] (*)
   Send feedback [link to bugzilla]
   --------------------------
   Check for updates
   License information
   Donate to LibreOffice [link to donation page] (*)
   --------------------------
   About LibreOffice


(*) this entry has a localized target. Fall-back is en-US
Comment 8 V Stuart Foote 2016-07-05 20:08:38 UTC
Created attachment 126084 [details]
the current Send Feedback landing page

@Oliver, *

(In reply to Olivier Hallot from comment #7)
> OK. After some discussion with the staff here is a suggestion
> 
> Help
>    LibreOffice Help (F1)
>    What is this?
>    --------------------------
>    Download Offine Help (*)
>    Download The Book of LibreOffice [link to latest LO Getting Started book
> in PDF] (*)
>    --------------------------
>    Questions & Answers [link to askbot.libreoffice.org] (*)
>    Get More Support [link to support webpage] (*)
>    Send feedback [link to bugzilla]
>    --------------------------
>    Check for updates
>    License information
>    Donate to LibreOffice [link to donation page] (*)
>    --------------------------
>    About LibreOffice
> 
> 
> (*) this entry has a localized target. Fall-back is en-US

This looks correctly organized with the separators as proposed. 

However, were your thinking of replacing the current "http://www.libreoffice.org/get-help/feedback/" target for the "Send feedback" action?

clip attached...

Would agree with Heiko that sending folks directly to our Bugzilla? Even the "guided" GUI would not be especially helpful. It seems the current feedback page has the right mix of options.
Comment 9 Olivier Hallot 2016-07-05 20:43:28 UTC
(In reply to V Stuart Foote from comment #8)

> However, were your thinking of replacing the current
> "http://www.libreoffice.org/get-help/feedback/" target for the "Send
> feedback" action?
> 

My bad! In the past the link was to BZ and I overlooked.

New proposal: drop "Send feedback" (replaced by "Get More Support" with link to localized http://www.libreoffice.org/get-help/feedback/ )



Help
   LibreOffice Help (F1)
   What is this?
   --------------------------
   Download Offine Help (*)
   Download The Book of LibreOffice [link to latest LO Getting Started book in PDF] (*)
   --------------------------
   Questions & Answers [link to askbot.libreoffice.org] (*)
   Get More Support [link to support webpage] (*)
   --------------------------
   Check for updates
   License information
   Donate to LibreOffice [link to donation page] (*)
   --------------------------
   About LibreOffice


(*) this entry has a localized target. Fall-back is en-US
Comment 10 Heiko Tietze 2016-07-05 20:55:47 UTC Comment hidden (no-value)
Comment 11 V Stuart Foote 2016-07-05 22:00:50 UTC
Looks good! Push it in and we can test it on master... then back port for 5.2.0 if nothing more is needed.
Comment 12 jani 2016-07-06 04:39:49 UTC
missing code pointer, missing topic<foo> to be a easyhack. Setting NEEDINFO, alternatively remove easyhack (which it seems to be)
Comment 13 sophie 2016-07-07 14:27:43 UTC
Just a note on the l10n side, these entries should be able to be hidden if a l10n team has not the resource and not the possibility to point to English content, so no fallback to English systematically but leave the decision to the translator for his language. Thanks - Sophie
Comment 14 Olivier Hallot 2016-07-07 16:43:58 UTC
Code pointers: Similar behaviour as this one

tdf@olivier-ntbk:~/git/core$ git grep SID_SEND_FEEDBACK
include/sfx2/sfxsids.hrc:#define SID_SEND_FEEDBACK                   (SID_SFX_START + 421)
sfx2/sdi/appslots.sdi:    SID_SEND_FEEDBACK
sfx2/sdi/sfx.sdi:SfxVoidItem SendFeedback SID_SEND_FEEDBACK
sfx2/source/appl/appserv.cxx:        case SID_SEND_FEEDBACK:
Comment 15 Olivier Hallot 2016-07-08 12:53:10 UTC
First patch submitted

https://gerrit.libreoffice.org/#/c/27028/
Comment 16 Yousuf Philips (jay) (retired) 2016-07-22 15:12:05 UTC
So here are my suggestions. :D

LibreOffice Help
What is this?
---
Online Help ( https://help.libreoffice.org/Main_Page )
Download Offline Help ( likely only enabled if offline help isnt installed, but wont be useful for locales that dont have localized help. e.g. arabic )
User Guides ( http://www.libreoffice.org/get-help/documentation/ )
---
Questions & Answers ( askbot.libreoffice.org )
Submit Feedback ( BSA or bugzilla or http://www.libreoffice.org/get-help/feedback/ )
Community Support ( http://www.libreoffice.org/get-help/community-support/ )
Professional Support ( http://www.libreoffice.org/get-help/professional-support/ )
---
Check for updates
License information
Donate to LibreOffice
---
About LibreOffice
Comment 17 Heiko Tietze 2016-07-23 07:58:40 UTC
(In reply to Yousuf (Jay) Philips from comment #16)
> Submit Feedback ( BSA or bugzilla or..

Again, so my concerns are not getting lost: We should attriute "Feedback" primarily as positive, for us and the users. And a link to the bugtracker is the wrong signal. So either feedback goes to http://www.libreoffice.org/get-help/feedback/ or we create a new page in order to start with success stories. 

Another idea is to create a page with the basic features along with an option to give a thumb up or down. For instance, I like the Navigator - click on thumbs up, I dislike the single line toolbar - thumbs down. The reliability increases with a large number of responses, and multiple votes, if not covered somehow, get averaged out.
Comment 18 Commit Notification 2016-08-11 14:25:09 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20469b56502687f85ce0fa9e5f7a50273daa3e91

tdf#96015 (part) links to Askbot in the Help menu

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 jani 2016-08-12 08:57:45 UTC
Seems solved
Comment 20 Yousuf Philips (jay) (retired) 2016-08-12 15:40:42 UTC
@Jan: i believe the patch was 1 of many.
Comment 21 Mirco Rondini 2016-10-12 09:47:29 UTC
hi, I would try to complete this easyhack, my suggestion:

Help menu writer/calc/etc...

LibreOffice Help   F1
What is this?
---
(REMOVED) Get help online... (http://hub.libreoffice.org/forum) //removed, open homepage
(NEW)LibreOffice homepage... ("http://www.libreoffice.org/")
(NEW)User Guides... (http://www.libreoffice.org/get-help/documentation/)
(NEW)Questions & Answers... (https://ask.libreoffice.org/)  //localized
Send Feedback...  (http://www.libreoffice.org/get-help/feedback/)
(NEW)Community support... (http://www.libreoffice.org/get-help/community-support/)
(NEW)Professional support... (http://www.libreoffice.org/get-help/professional-support/)
---
Check for updates...
License Information...
(NEW)Donate to LibreOffice... (http://www.libreoffice.org/donate/)
---
About LibreOffice
Comment 22 Olivier Hallot 2016-10-12 12:52:48 UTC
(In reply to Mirco Rondini from comment #21)
> hi, I would try to complete this easyhack, my suggestion:
> 

Please beware that this bug has already been started, and 2 patches were done. One is committed and the other is in review. The patches are aligned to the latest approval by the UX team.
Comment 23 jani 2016-10-13 06:43:32 UTC
Change to assigned

Oliver@ can you please add a few words of what is actually missing ?
Comment 24 jani 2016-10-13 11:55:15 UTC
That was not the intention, really no need to abandon your patch !!!! Oliver has had his patch hanging for a while so I expected him to abandon his....it is more important for you to get your first patch merged.
Comment 25 Olivier Hallot 2016-10-13 12:30:54 UTC
There is no such thing as one developer throwing out hours of good work to accommodate another dev work that just poped up with the same and overlapping patch, without a true technical justification.

The solution of this patch merge conflict is known and happens all the time.

I can't be blamed if developers, newbies or not, abandon their patch. It is nevertheless a sad attitude and Mirco is most welcome to patch LibreOffice  fixing the merge conflict.
Comment 26 Yousuf Philips (jay) (retired) 2016-10-15 19:36:57 UTC
*** Bug 62005 has been marked as a duplicate of this bug. ***
Comment 27 Yousuf Philips (jay) (retired) 2016-10-15 19:43:16 UTC
Some other links i was pondering about for live help with no/minimal signup process

IRC - http://webchat.freenode.net/?channels=libreoffice or https://wiki.documentfoundation.org/Website/IRC

Reddit - https://www.reddit.com/r/libreoffice/
Comment 28 Commit Notification 2016-10-19 16:09:04 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e91a1abe4c53ea3a1ac59e3c1d5dddf98141a4ee

tdf#96015 (part) link to Doc'tation in Help menu

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 jani 2016-10-20 12:20:15 UTC
I assume the bug can be closed.
Comment 30 Yousuf Philips (jay) (retired) 2016-10-20 12:36:06 UTC
@jan: No it isnt completely fixed as we have many entries to add to the help menu. Olivier will close it once everything is finished.
Comment 31 jani 2016-10-20 12:58:49 UTC
(In reply to Yousuf Philips (jay) from comment #30)
> @jan: No it isnt completely fixed as we have many entries to add to the help
> menu. Olivier will close it once everything is finished.

I can follow that, but I do not see the many entries references or at least to keep it as an easyhack, someone should add a list of missing entries, so a contributor knows what to do. Added needsUXEval.
Comment 32 Olivier Hallot 2016-10-20 13:23:42 UTC
(In reply to Yousuf Philips (jay) from comment #16)
> So here are my suggestions. :D
> 
> LibreOffice Help
> What is this?
> ---
> Online Help ( https://help.libreoffice.org/Main_Page )
> Download Offline Help ( likely only enabled if offline help isnt installed,
> but wont be useful for locales that dont have localized help. e.g. arabic )
> User Guides ( http://www.libreoffice.org/get-help/documentation/ )
> ---
> Questions & Answers ( askbot.libreoffice.org )
> Submit Feedback ( BSA or bugzilla or
> http://www.libreoffice.org/get-help/feedback/ )
> Community Support ( http://www.libreoffice.org/get-help/community-support/ )
> Professional Support (
> http://www.libreoffice.org/get-help/professional-support/ )
> ---
> Check for updates
> License information
> Donate to LibreOffice
> ---
> About LibreOffice

Summarizing, with latest additions from comment#27

* LibreOffice Help (already exist)
* Download Offline Help (open)
* User Guides (done)
---
* Question and Answers (Done. Was changed to 'Get Help Online', after some NL - fr, ru - objected that they don't use askbot but AOO forums)
* Submit Feedback (already exist)
* Community support (open)
* IRC (new, open)
* Reddit (new, open)
* Professional Support (open)
---
* Check for updates (already exist)
* License information (already exist)
* Donate to LibreOffice (already exist)
---
* About LibreOffice (already exist)

Please confirm this is a consensus.
Comment 33 Heiko Tietze 2016-10-26 13:48:08 UTC
(In reply to Olivier Hallot from comment #32)
>...
> Please confirm this is a consensus.

Opposing Jay's comment 27 I believe that Reddit is not known outside the scene, and IRC is also not what the ordinary user wants to use. However why not push those Open Source platforms a bit? And since there was no other reply within the last couple of days I'd confirm the proposal from the UX POV.
Comment 34 V Stuart Foote 2016-10-26 14:47:39 UTC
(In reply to Olivier Hallot from comment #32)

> Summarizing, with latest additions from comment#27
> 
> * LibreOffice Help (already exist)
> * Download Offline Help (open)
> * User Guides (done)
> ---
> * Question and Answers (Done. Was changed to 'Get Help Online', after some
> NL - fr, ru - objected that they don't use askbot but AOO forums)
> * Submit Feedback (already exist)
> * Community support (open)
> * IRC (new, open)
> * Reddit (new, open)
> * Professional Support (open)
> ---
> * Check for updates (already exist)
> * License information (already exist)
> * Donate to LibreOffice (already exist)
> ---
> * About LibreOffice (already exist)
> 
> Please confirm this is a consensus.

Thanks Oliver, +1 on addition of both a Reddit entry and an IRC entry.

Sidebar--could folks check the "User Guides" behavior. With current master (2016-10-25) I get directed to the libreoffice.org home landing page with the silly "get-it now" download popup, and not directly to the "www.libreoffice.org/get-help/documentation" web page.  

Also, do we have to go to the web pages? IMHO the wiki has better organization of the documentation--and direct links for any existing localizations-- so for the Help menu link "User Guides..." the http://wiki.documentfoundation.org/Documentation/Publications link is a better UX.
Comment 35 jani 2016-10-26 15:02:04 UTC
Removing easyHack as it does not seem that the discussion has ended, and when I read down the comments it is not clear what is missing.

An easyHack requires code pointers, and clear instructions on what to do, so at least a list of the missing entries which are agreed upon is needed.

It seems to me the work consist of:
> * Download Offline Help (open)
> ---
> * Community support (open)
> * IRC (new, open)
> * Reddit (new, open)
> * Professional Support (open)

But where should they point to ? 

also there seems to be some open discussion web page versus wiki.

Bear in mind, I read all the comments as a newbie, who want to help and do not know a lot of the history.
Comment 36 V Stuart Foote 2016-10-26 15:34:56 UTC
@Jan, * 

Sorry, seems my last comment added to the noise, in fact Oliver has been tackling this from the start and it probably should not have been easyHack'd

@Oliver, I went ahead and just assigned it to you, back yourself out if uncomfortable with that, or if you prefer to reset "easyHack" for it and have Jan mentor with you once we pin down the "final" menu structure.

Stuart
Comment 37 Yousuf Philips (jay) (retired) 2016-10-26 16:33:57 UTC
(In reply to Olivier Hallot from comment #32)
> * User Guides (done)

This sends me to http://hub.libreoffice.org/documentation/?LOlocale=en-US which then sends me to http://www.libreoffice.org/?LOlocale=en-US

> ---
> * Question and Answers (Done. Was changed to 'Get Help Online', after some
> NL - fr, ru - objected that they don't use askbot but AOO forums)

This sends me to http://hub.libreoffice.org/forum/?LOlang=en which then sends me to http://www.libreoffice.org/?LOlang=en

'Get Help Online' isnt a suitable name for a link that just links to the LO forums and we are also adding links to irc and reddit which can also be considered getting help online. If this link only links to the forums, then it should be renamed to 'Forums' or something like that and a Question and Answers entry should still be added to link to https://ask.libreoffice.org/
Comment 38 Olivier Hallot 2016-10-26 17:51:14 UTC
(In reply to Yousuf Philips (jay) from comment #37)
> (In reply to Olivier Hallot from comment #32)
> > * User Guides (done)
> 
> This sends me to http://hub.libreoffice.org/documentation/?LOlocale=en-US
> which then sends me to http://www.libreoffice.org/?LOlocale=en-US

Infra says the right way to do it is to have a hub in TDF infra to forward to the right place. That way we don't need to hard-code the URL in C++, which saves in maintenance of older releases.

The current settings still depended on TDF infra to set the final destination. 
I expect (hope) this will be sorted by infra on 5.3 release.

https://redmine.documentfoundation.org/issues/2101

> 
> > ---
> > * Question and Answers (Done. Was changed to 'Get Help Online', after some
> > NL - fr, ru - objected that they don't use askbot but AOO forums)
> 
> This sends me to http://hub.libreoffice.org/forum/?LOlang=en which then
> sends me to http://www.libreoffice.org/?LOlang=en

https://redmine.documentfoundation.org/issues/1983
https://goo.gl/xmG3lF

> 
> 'Get Help Online' isnt a suitable name for a link that just links to the LO
> forums and we are also adding links to irc and reddit which can also be
> considered getting help online. If this link only links to the forums, then
> it should be renamed to 'Forums' or something like that and a Question and
> Answers entry should still be added to link to https://ask.libreoffice.org/

Final settings of hub.l.o will forward fr, ru and cn to proper forum URL's (out of TDF control) and all other languages to proper askbot.l.o within TDF. Therefore:

1) fr, ru, cn are exceptions to the rule

2) a specific entry "Forum" will trigger the need of forums in all languages, which is not what we want today. Askbot was choosen instead of a generic forum around 2012.

Summary: Still WIP in the infra side.
Comment 39 Jean-Baptiste Faure 2016-10-27 05:05:20 UTC
(In reply to Olivier Hallot from comment #32)
> * Question and Answers (Done. Was changed to 'Get Help Online', after some
> NL - fr, ru - objected that they don't use askbot but AOO forums)

It is not true for fr NL community. We do not not use askbot but not AOO forum too. I think we can't send user searching an answer to a forum who is not friendly with LO project and TDF and is not under the technical control of LO community.
Our main entry point to get help in French is 
https://fr.libreoffice.org/get-help/poser-une-question
This entry point is mainly dedicated to users who are not comfortable with mailing lists.

Best regards. JBF
Comment 40 sophie 2016-10-27 09:08:31 UTC
(In reply to Olivier Hallot from comment #38)
> (In reply to Yousuf Philips (jay) from comment #37)
> > (In reply to Olivier Hallot from comment #32)
[...]
> Final settings of hub.l.o will forward fr, ru and cn to proper forum URL's
> (out of TDF control) and all other languages to proper askbot.l.o within
> TDF. Therefore:

As I told you already several time, fr was an example I give you and absolutely not what the FR community wants to have there, so please do not add the links on your own, but ask the concerned communities what they really want to have. That should be up to the community to decide what to put there and they should be able to change the link by themselves too. Again this should be discussed on the L10n list. Thanks.
Comment 41 Olivier Hallot 2016-10-27 12:26:53 UTC
@Sophie: The community response in l10n was less than satisfactory, and the clock is ticking.

https://goo.gl/YliWLS in July 11,2016
https://goo.gl/4pSnjX in Aug, 22, 2016

So 
1) I have no power to add or set links, that's infra mission.
2) I didn't invent the AOO stuff for the fr. You said explicitly as a example of community that prefers AOO and not link to fr-askbot. You didn't make it clear enough that AOO is *one of* the possible outcome.
3) Can the French NL team set the right URL for the link?
Comment 42 sophie 2016-10-27 12:33:44 UTC
(In reply to Olivier Hallot from comment #41)
> @Sophie: The community response in l10n was less than satisfactory, and the
> clock is ticking.
> 
> https://goo.gl/YliWLS in July 11,2016
> https://goo.gl/4pSnjX in Aug, 22, 2016

In that case, let me know and I'll ping people directly
> 
> So 
> 1) I have no power to add or set links, that's infra mission.

and that should be l10n team mission, what I asked from the beginning.

> 2) I didn't invent the AOO stuff for the fr. You said explicitly as a
> example of community that prefers AOO and not link to fr-askbot. You didn't
> make it clear enough that AOO is *one of* the possible outcome.

I'm not the l10n FR lead and I said numerous time that it was an example that some communities have other forum than Ask

> 3) Can the French NL team set the right URL for the link?

See comment #39 Jean-Baptiste gave you the link.
https://fr.libreoffice.org/get-help/poser-une-question
Comment 43 Heiko Tietze 2017-02-16 12:16:22 UTC
Suggest to close this ticket as fixed, Olivier.
Comment 44 Olivier Hallot 2017-02-16 13:02:20 UTC
Closing.
Comment 45 V Stuart Foote 2017-03-30 18:11:35 UTC
*** Bug 106874 has been marked as a duplicate of this bug. ***