Bug Hunting Session
Bug 96022 - Keyboard shortcuts with CTRL (copy/cut/paste/undo/redo...) not working in Linux Hebrew keyboard layout
Summary: Keyboard shortcuts with CTRL (copy/cut/paste/undo/redo...) not working in Lin...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 107426 111800 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators RTL-Hebrew
  Show dependency treegraph
 
Reported: 2015-11-23 20:46 UTC by ilgl76
Modified: 2017-11-16 20:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ilgl76 2015-11-23 20:46:38 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.2.2

Hi.
While typing Hebrew (using English UI) non of the keyboard shortcuts works (it's very annoying). When switching back to English everything works again.
Please configure all LibreOffice keyboard shortcuts to work as in English (US), although the user types in Hebrew. 
Thanks !

Reproducible: Always

Steps to Reproduce:
1.Switch keyboard layout to Hebrew
2.
3.
Actual Results:  
keyboard shortcuts doesn't work

Expected Results:  
keyboard shortcuts should work as you were in en-us layout.

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?yes. many times....
Comment 1 Dudi Maroshi 2016-05-21 16:53:41 UTC
Tested for Writer, Calc, Impress.
Tested with Ubuntu 16.04 Desktop with Hebrew keyboard layout and US keyboard layout.

Scenario to reproduce:
1. Open a new document
2. Change keyboard layout to Hebrew
3. Select text using mouse
4. Cut the selection using keyboard shortcut CTRL-X

Expected result:
5. Selected text is removed

Actual result:
5. No change

Additional diagnostics.
The CTRL key is not functional when the Hebrew keyboard layout is in effect.
The CTRL key if fully functional when change to US keyboard layout.

The effected short cuts are the mostly used:
1. Copy - CTRL-C
2. Paste - CTRL-V
3. Select All - CTRL-A
4. Cut - CTRL-X
5. Find - CTRL-H
6. Find & Replace - CTRL-F
7. Undo - CTRL-Z
8. Redo - CTRL-Y
Actually all keyboard shortcuts involving CTRL

Workarounds:
1. Use mouse context menu selection(right click)
2. Select from Menu bar items
3. Use ALT-E shortcut keys to select from Menu bar items

Actual condition:
Libre Office NOT usable for extensive Hebrew editing (Writer/Impress). Since most used keyboard shortcuts are not usable.
undo/redo/copy/paste/cut
Users are not willing to learn special keyboard shortcuts for Hebrew keyboard layout.
Comment 2 Dudi Maroshi 2016-05-21 17:35:12 UTC
Testing this bug on Windows 10 with Libre Office 5.0.3.2
The CTRL key is fully functional.

Upgraded Libre Office to 5.1.3.2 on Windows 10
Testing this bug on Windows 10 with Libre Office 5.1.3.2
The CTRL key is fully functional.

Apparently this bug is Linux related.
Comment 3 Buovjaga 2016-05-26 12:18:48 UTC
NEW per comment 1
Comment 4 QA Administrators 2017-09-01 11:16:48 UTC Comment hidden (obsolete)
Comment 5 ilgl76 2017-09-01 14:55:48 UTC
2017-09-01:
The bug still exists.
LibreOffice Version: 5.3.1.2
Build ID: 1:5.3.1-0ubuntu2
Ubuntu 17.04

No changes from previous versions
Comment 6 Maxim Monastirsky 2017-10-14 20:18:30 UTC
*** Bug 107426 has been marked as a duplicate of this bug. ***
Comment 7 Maxim Monastirsky 2017-10-14 20:24:46 UTC
*** Bug 111800 has been marked as a duplicate of this bug. ***
Comment 8 Hanan Sela 2017-10-15 05:58:03 UTC
In LO 5.1.6.2 on Ubuntu 16.04, The problem still exists.
Comment 9 Dudi Maroshi 2017-10-15 07:32:22 UTC
Problem persist and reproduced with latest LO release 5.4.2.2
This bug is related to keyboard layout infrastructure.
Since all LO products are affected.

Tested on Ubuntu 16.04.
Comment 10 ilgl76 2017-10-31 20:29:07 UTC
Problem solved in Ubuntu 17.10 LibreOffice 5.4.1.2 !
Comment 11 Buovjaga 2017-11-01 10:09:04 UTC
(In reply to ilgl76 from comment #10)
> Problem solved in Ubuntu 17.10 LibreOffice 5.4.1.2 !

Dudi: it appears the problem was related to Ubuntu Unity. 17.10 ships with GNOME instead of Unity. When you have time, could you try with Ubuntu 17.10?
Comment 12 Omer Zak 2017-11-15 22:18:23 UTC
Works for me at:

Version: 6.0.0.0.alpha1+
Build ID: 9050854c35c389466923f0224a36572d36cd471a
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
The desktop being used is Xfce, Version 4.12 as distributed by Debian.
The Hebrew keyboard being used is:
  - Generic 105-key (Intl PC)
  - Change layout option: Both Shift keys together
  - Compose key: none
  - Keyboard layout: English (US)
                     Hebrew
Comment 13 Buovjaga 2017-11-16 14:32:45 UTC
I guess we can close.
Comment 14 Eyal Rozenberg 2017-11-16 20:12:26 UTC
Works for me with 5.4.1.2 release with Lubuntu 17.10 64bit.
Comment 15 Lior Kaplan 2017-11-16 20:43:27 UTC
Thank you guys for the check and double check.