Bug 96118 - list of combobox closes when clicking on its scroll bar slider
Summary: list of combobox closes when clicking on its scroll bar slider
Status: RESOLVED DUPLICATE of bug 96119
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-11-28 18:41 UTC by Regina Henschel
Modified: 2015-12-17 09:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-11-28 18:41:32 UTC
Start Writer. Open the font name list in the toolbar. Click on the slider in the vertical scrollbar of that list.
Expected behavior: You can move the slider with the mouse.
Seen behavior: The list closes immediately.

That happens to font size drop-down list too.

The same happens to these lists in the Sidebar.

I see this problem in
Version: 5.2.0.0.alpha0+
Build-ID: a8860122fecbaa932a48f41a38077f621275be9d
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-27_10:34:00
Gebietsschema: de-DE (de_DE)

It was OK in
Version: 5.1.0.0.alpha1+
Build ID: f271602f7193ddf584ea58dc6a468e6842d0781e
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-08_22:37:35
Locale: de-DE (de_DE)
Comment 1 Jacques Guilleron 2015-11-29 11:45:24 UTC
Hi Regina,

Confirmed with 
LO 5.2.0.0.alpha0+ Build ID: 03c37cee476d14d1d8644ccc7ea5c69d74d9c7f9
TinderBox: Win-x86@42, Branch:master, Time: 2015-11-28_00:15:51
Locale: fr-FR (fr_FR)
Works with
LO 5.1.0.0.alpha1+ Build ID: f6bc5b79c31225c02e9500d0ced4bd26f998f82b
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-24_01:07:47
Locale: fr-FR (fr_FR)
& windows 7 Home
disabling OpenGL do no change to this issue.
Comment 2 Maxim Monastirsky 2015-12-01 08:29:58 UTC
Seems to affect *any* combobox.
Comment 3 Laurent BP 2015-12-01 16:55:52 UTC
The problem is not only the scroll bar, but also selecting a different value in list does not change value.
It seems to affect ALL combobox in all modules in all UI (toolbar, sidebar, dialog box).

I found 1 exception: in Tools > Options > LibreOffice > View: changing icon style does not change value in combobox, but DOES change icon style in UI. On the opposite, other combobox has no effect.

Workaround: use arrow key to modify value in combobox

Win 7, Version: 5.1.0.0.beta1-buildfix1
Build ID: 13010a13177025f633c9b85adcb3edf6920e44e3
Threads 4; Ver: Windows 6.1; Render: default; 

Locale : fr-FR (fr_FR)
Comment 4 Maxim Monastirsky 2015-12-01 17:34:14 UTC
(In reply to Laurent BP from comment #3)
> The problem is not only the scroll bar, but also selecting a different value
> in list does not change value.
There is a separate bug for it - Bug 96119.
Comment 5 Jared 2015-12-07 21:44:00 UTC
Also seeing this in Version: 5.1.0.0.beta2 on Win10_x64
Comment 6 Maxim Monastirsky 2015-12-17 09:04:09 UTC

*** This bug has been marked as a duplicate of bug 96119 ***