Bug 96127 - Android: No UI visible
Summary: Android: No UI visible
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-29 09:37 UTC by raal
Modified: 2016-09-16 00:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
printscreen (85.79 KB, image/png)
2015-11-29 09:37 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2015-11-29 09:37:12 UTC
Created attachment 120869 [details]
printscreen

Android build from here: http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/current/
master~2015-11-29_00.24.42_LibreOfficeViewer-strippedUI-debug.apk 29-Nov-2015 01:39 

No UI visible, button toolbar lost.
Comment 1 Robinson Tryon (qubit) 2015-12-03 18:31:47 UTC
(In reply to raal from comment #0)
> Created attachment 120869 [details]
> printscreen
> 
> Android build from here:
> http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-
> Hosting/current/
> master~2015-11-29_00.24.42_LibreOfficeViewer-strippedUI-debug.apk
> 29-Nov-2015 01:39 
> 
> No UI visible, button toolbar lost.

NOREPRO with current daily build. UI visible on application start and while viewing/editing documents:
http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/current/master~2015-12-03_04.12.48_LibreOfficeViewer-strippedUI-debug.apk

Raal: Can you still repro with latest build? If so, what hardware are you using for your tests?

Status -> NEEDINFO
Comment 2 raal 2015-12-03 18:53:39 UTC
(In reply to Robinson Tryon (qubit) from comment #1)
> (In reply to raal from comment #0)
> 
> Raal: Can you still repro with latest build? If so, what hardware are you
> using for your tests?
> 

Hello, I can still repro with current build. Xiaomi MiPad, android 4.4.4
Comment 3 alexfonggX 2015-12-06 12:28:52 UTC
I have faced the same problem on my nexus 7 (4.4.2) and samsung s2 (4.2.2) as well. The bug does not affect devices of Android 5+ (tested with emulators), perhaps due to how toolbar is implemented.
Comment 4 Commit Notification 2016-01-04 21:09:43 UTC
AlexF committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa354c9ae940ae12abf26b1d8c62836d4e50dfb4

tdf#96127 Android: No UI visible

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2016-09-15 20:48:42 UTC
Hi,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Regards