Bug 96129 - Shift click to select multiple pictures does not work
Summary: Shift click to select multiple pictures does not work
Status: RESOLVED DUPLICATE of bug 34438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-29 11:19 UTC by stragu
Modified: 2017-04-19 21:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file to test bug (18.34 KB, application/vnd.oasis.opendocument.text)
2015-11-29 11:19 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2015-11-29 11:19:00 UTC
Created attachment 120871 [details]
file to test bug

Steps to reproduce:
- select one clipart by clicking on it
- try to add the second clipart to the selection by using shift + click

Expected result:
- both pictures are selected

Actual result:
- none of the pictures are selected

Note that there is no problem when doing the same for the two rectangle shapes.

I don't seem to have had this issue for ages until today... It felt like a flashback of the old long-standing Bug 37960. I thought it actually was a regression on the corresponding bugfix, but the behaviour is different. The attached file is actually the same example document as for Bug 37960.
Comment 1 raal 2015-11-29 12:37:15 UTC
Reproducible with Version: 4.3.0.0.alpha1+ and 5.0.2.2 and Version: 5.1.0.0.alpha1+
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-11-17_00:57:30
Comment 2 QA Administrators 2017-01-03 19:35:26 UTC Comment hidden (obsolete)
Comment 3 stragu 2017-01-04 08:08:47 UTC
Reproduced as described with sample document, on KXStudio 14.04, with LO as follows:

Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 4 Regina Henschel 2017-04-19 21:34:24 UTC
The underlying problem is, that images in Writer are no drawing objects. Bug 34438 is the oldest and a comprehensive one of all the duplicates.

*** This bug has been marked as a duplicate of bug 34438 ***