Bug 96157 - After multiple select of cells, it is possible to copy on a protected cell
Summary: After multiple select of cells, it is possible to copy on a protected cell
Status: RESOLVED DUPLICATE of bug 106965
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Jean-Sebastien Bevilacqua
URL:
Whiteboard:
Keywords:
Depends on: 106952
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 15:38 UTC by Olivier MORIN
Modified: 2018-02-21 10:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Video of the bug (413.00 KB, video/avi)
2015-11-30 15:38 UTC, Olivier MORIN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier MORIN 2015-11-30 15:38:01 UTC
Created attachment 120897 [details]
Video of the bug

A1 B1 and D1 are unprotected, but C1 is protected
A2 B2 and D2 are unprotected, but C2 is protected
Clic on A1, Ctrl-Clic on B1 and D1
Sheet protection is enabled with no selection on protected cells.
Move to B2, paste... D2 witch is protected is affected by the paste.
It should not...
Comment 1 Buovjaga 2015-12-01 09:02:58 UTC
If you are using 4.2, could you test with version 5 to see, if the problem still exists?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Olivier MORIN 2015-12-01 09:31:42 UTC
Yes, with libreoffice 5.0.2.2 and OpenOffice 4.1.2.
Comment 3 Buovjaga 2015-12-01 09:52:40 UTC
Reproduced, C2 is affected.

I tried to find a duplicate report, but failed.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)
Comment 4 Olivier MORIN 2015-12-01 15:14:55 UTC
Importance MINOR !

Not so MINOR when you risk to delet protected data...
Comment 5 Buovjaga 2015-12-01 15:41:10 UTC
(In reply to Olivier MORIN from comment #4)
> Importance MINOR !
> 
> Not so MINOR when you risk to delet protected data...

Workaround is pressing undo.

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Minor - Does the bug require users to not use some feature? Yes, you can't use multi-selected paste on protected cells.
Comment 6 Jean-Sebastien Bevilacqua 2017-03-29 13:50:08 UTC
Reproducible on 5.4.
I'm working on it
Comment 7 Timur 2017-05-18 08:33:28 UTC
Although this one is older, Bug 106965 is being worked on, so I mark this one as a duplicate.

*** This bug has been marked as a duplicate of bug 106965 ***