Bug 96166 - Popup Windows do not get focus
Summary: Popup Windows do not get focus
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-01 06:04 UTC by KFlash
Modified: 2018-01-29 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KFlash 2015-12-01 06:04:34 UTC
When using libreOffice in a productive way, reads using shortcuts as offen as possible, the user experience is crippled by pop up windows that do not get focus automatically.

i.e. If you want to insert unformatted text you want to press 
Ctrl+Shift+V -> Enter

But the popup will not get focus. So you are forced to:
Ctrl+Shift+V -> move mouse and click on window -> enter

Frustrating.

Btw: I newer understood why "insert unformatted text" is a "special usecase" while "insert text with all formatting (that will never fit my new document I'm writing)" is the standard. In 85% of cases, I want to see the pasted text in the same format as the rest of MY document and not the source document.
Comment 1 Nils Smeds 2015-12-02 12:01:56 UTC
I think this is may be a duplicate of #83125

I am also haunted by this behaviour and can not find out if there is any setting in XFCE/xfwm4 that can be tweaked to have pop-up dialogue windows to have automatic focus when the LibreOffice program is in focus.

I have not tried to set (what I believe is a general option) new windows get automatic focus because of problems of applications stealing focus unintentionally.

Is there anyone that can give a hint how to circumvent this problem?
Comment 2 Adolfo Jayme Barrientos 2015-12-03 08:23:21 UTC

*** This bug has been marked as a duplicate of bug 83125 ***
Comment 3 KFlash 2015-12-04 17:13:16 UTC
I do not use Lubuntu. I use KDE / Kubuntu.
Comment 4 QA Administrators 2017-01-03 19:42:35 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2017-06-26 19:02:06 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2018-01-02 10:14:52 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2018-01-29 10:35:53 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180129