Download it now!
Bug 96181 - FILEOPEN: SVG: Implement support for <use> element
Summary: FILEOPEN: SVG: Implement support for <use> element
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2015-12-01 14:32 UTC by Xisco Faulí
Modified: 2018-06-20 17:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
simple sample (514 bytes, image/svg+xml)
2015-12-01 14:32 UTC, Xisco Faulí
Details
another sample (419 bytes, image/svg+xml)
2015-12-08 22:24 UTC, Xisco Faulí
Details
yet another (407 bytes, image/svg+xml)
2015-12-08 23:51 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2015-12-01 14:32:44 UTC
Created attachment 120929 [details]
simple sample

Currently, SVG filter doesn't support this element. Some samples attached
Comment 1 Xisco Faulí 2015-12-01 14:34:53 UTC
attachment 49574 [details]
Comment 2 Xisco Faulí 2015-12-01 14:38:58 UTC
attachement 113962
Comment 3 Xisco Faulí 2015-12-01 14:39:12 UTC
attachment 113962 [details]
Comment 4 Xisco Faulí 2015-12-01 14:48:13 UTC
attachment 87764 [details]
Comment 5 Xisco Faulí 2015-12-01 14:58:54 UTC
attachment 118095 [details]
Comment 6 Xisco Faulí 2015-12-08 22:24:31 UTC
Created attachment 121150 [details]
another sample
Comment 7 Xisco Faulí 2015-12-08 23:50:38 UTC
Comment 3 is incorrect. Correct one -> attachment 113964 [details].
Besides, attachment 118095 [details] is not related to this issue, my bad
Comment 8 Xisco Faulí 2015-12-08 23:51:06 UTC
Created attachment 121153 [details]
yet another
Comment 9 A (Andy) 2015-12-20 21:47:26 UTC
Reproducible with LO 5.0.3.2, Win 8.1

no coloured dots instead of black, red and blue dots
Comment 10 Xisco Faulí 2015-12-21 10:04:26 UTC
A fix for the issue is waiting for review in gerrit: https://gerrit.libreoffice.org/#/c/20483/
Comment 11 Commit Notification 2015-12-22 13:15:44 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=307421ba933361eaa34c12d23b0f261393ab51d8

tdf#96181 SVG: Add support for <use> element

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2015-12-28 10:57:06 UTC
Fixed after 307421ba933361eaa34c12d23b0f261393ab51d8