Bug 96202 - UI: Same acceleration-key in context menu
Summary: UI: Same acceleration-key in context menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-02 11:05 UTC by baffclan
Modified: 2016-10-25 19:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
context menu (28.37 KB, image/jpeg)
2015-12-02 11:05 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2015-12-02 11:05:08 UTC
Created attachment 120956 [details]
context menu

Same acceleration-key in context menu

Steps to Reproduce:
1. Start LibO-Dev
2. New Calc File
3. Select a Rows and Right click
4. Appear context menu

JDo3u : Insert Rows A~bowe
H85UD : Insert Rows ~Below

Windows 7 Pro
Version: 5.2.0.0.alpha0+ (x64)
Build ID: e7c78e67292ad93c6a4a0772d8b06a0e6e7d26c8
Threads 4; Ver: Windows 6.1; Render: GL; 

TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-30_22:37:14
Locale: ja-JP (ja_JP)
Comment 1 Julien Nabet 2015-12-02 20:59:58 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

code pointer: http://opengrok.libreoffice.org/xref/core/sc/source/ui/src/hdrcont.src#67

ux-team: any idea for appropriate acceleration-keys here?
Comment 2 V Stuart Foote 2015-12-02 22:33:57 UTC
@Jay,

When you cleaned the up the column and row context menus for calc, you inadvertently duped the A~bove accelerator with the ~Below in the sc/source/ui/src/hdrcont.src

=-ref-=

https://gerrit.libreoffice.org/16012/

https://gerrit.libreoffice.org/15831/
Comment 3 Yousuf Philips (jay) (retired) 2015-12-07 15:14:35 UTC
Returned the accelerator back to how it was.

https://gerrit.libreoffice.org/20437
Comment 4 Commit Notification 2015-12-08 09:13:35 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14fb1d6421802be3b69ff50dcd9703c2596df4e3

tdf#96202 Revert accelerator back to 'I'

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-12-08 12:08:46 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fcf968d71de1212bde327db0156f194d679cc65&h=libreoffice-5-1

tdf#96202 Revert accelerator back to 'I'

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.