Download it now!
Bug 96206 - Copying slide which non-default master page contains text duplicates that master
Summary: Copying slide which non-default master page contains text duplicates that master
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:5.2.0 target:5.1.0.1
Keywords: regression
Depends on:
Blocks: Master-Slide
  Show dependency treegraph
 
Reported: 2015-12-02 14:53 UTC by Mike Kaganski
Modified: 2017-12-07 06:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with a non-default master page with a text (12.77 KB, application/vnd.oasis.opendocument.presentation)
2015-12-02 14:53 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2015-12-02 14:53:55 UTC
Created attachment 120961 [details]
Presentation with a non-default master page with a text

Steps to reproduce:
1. Create a new presentation
2. Switch to Slide Master view, add a new master page, add a text box (F2) with some arbitrary text on it.
3. Switch back to normal view, select the first slide, apply new master to it (open Master Pages deck in sidebar, souble-ckick on newly created master).
4. Right-click on the first slide thumbnail, copy it, then paste to create a copy of the slide.

Expected result: newly inserted slide inherits master page of the first slide

Actual result: a new master page is created having the name of original one with added underscore "_"; newly inserted slide is connected to it.

Further pastes don't add new masters.

Attached file may be used to easily reproduce it: the second slide is already connected to a master "New" having a text box; simply copy the slide and paste it back to see master duplication.

Not reproducible prior to 4.3 -> regression.
Comment 1 Cor Nouws 2015-12-02 16:21:06 UTC
thanks for Filing Mike.
I confirm this in a recent daily for 5.2.0 > New
Comment 2 Mike Kaganski 2015-12-02 20:58:44 UTC
regression since commit aa822c44b758fe312a3a052f890f53418adc5f6b
Author: Muthu Subramanian <sumuthu@collabora.com>
Date:   Tue Dec 10 17:20:34 2013 +0530

     n#753460: Copying slides having same master page name.

     Has part feature of getting hashes of SdPages.
     (Misses hashing text, images, etc).

Working on it
Comment 3 Mike Kaganski 2015-12-03 09:21:45 UTC
Posted a patch to gerrit: https://gerrit.libreoffice.org/20367
Comment 4 Commit Notification 2015-12-14 09:07:14 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6381fe554aec600d13d0359903216811d644dd36

tdf#96206: Avoid scaling objects while copying to clipboard

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-12-14 11:11:39 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02d09f424cac957e2d214a3fc6eebac14b3852a7&h=libreoffice-5-1

tdf#96206: Avoid scaling objects while copying to clipboard

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.