Download it now!
Bug 96262 - Allow Inserting Image to Calc Header from Insert -> Header Dialog
Summary: Allow Inserting Image to Calc Header from Insert -> Header Dialog
Status: RESOLVED DUPLICATE of bug 74146
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-05 07:46 UTC by Wes
Modified: 2016-01-10 17:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Report generated by Calc (170.04 KB, application/pdf)
2015-12-08 18:54 UTC, Wes
Details
Report generated by Excel (127.62 KB, application/pdf)
2015-12-08 18:55 UTC, Wes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wes 2015-12-05 07:46:07 UTC
In Excel I'm able to attach a graphic file (company logo) in the header section and in Calc I can't do that.  If this feature could be added that would be great than I don't have to resort to keep on using Excel for certain public reports.

I don't know if this is Calc specific but I do know Word document headers are able to handle graphic (jpg) files.  I haven't tried to upload a graphic in Writer yet.

Thanks and keep on doing the great work!
Comment 2 Joel Madero 2015-12-05 16:05:55 UTC
Hi Wes,

Wow I learned something new - it is not obvious but it is possible to do this :)


Format -> Page -> Header -> (click) More . . .

Dialog opens

Click "Background"

"As" (dropdown) select "Graphic"

Browse for your logo.


I know not entirely straight forward so let's change this bug report a bit to request it move to the most obvious spot :)
Comment 3 m.a.riosv 2015-12-05 18:16:25 UTC
Seems a duplicate.

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 74146 ***
Comment 4 Wes 2015-12-08 18:54:38 UTC
Created attachment 121146 [details]
Report generated by Calc
Comment 5 Wes 2015-12-08 18:55:29 UTC
Created attachment 121147 [details]
Report generated by Excel
Comment 6 Wes 2015-12-08 18:58:49 UTC
Thanks for the reply and now I know how to attach a file to the header.  Here's a scaling problem I have though.

I've attached two files.  A report generated by Calc and Excel.  You can see the Excel report has our graphic scaled correctly on the right side of the header while the Calc report has the graphic on the right side but not scaled correctly.  Let me know if there is a way to do this.
Comment 7 Joel Madero 2015-12-08 20:56:39 UTC
Moving to correct status.
Comment 8 Jean-Baptiste Faure 2016-01-10 17:06:47 UTC
Please keep the original request which is already implemented in LO 5.0.

For the scaling problem, which is probably a defect (instead of an enhancement request like there), please file a dedicated bug report. Don't forget to attach a test file in which all confidential data will have been removed to this new bug report.

Closing as duplicate of bug 74146 again. If you disagree, please argue.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 74146 ***