Bug 96271 - OpenGL rendering problems with impress
Summary: OpenGL rendering problems with impress
Status: RESOLVED DUPLICATE of bug 95648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-12-05 16:01 UTC by Pierre C
Modified: 2015-12-07 17:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
examples (539.30 KB, application/vnd.oasis.opendocument.presentation)
2015-12-05 16:01 UTC, Pierre C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2015-12-05 16:01:48 UTC
Created attachment 121052 [details]
examples

Easy to reproduce
just open attached file

Slides goes by two
The slide that rise the problem and a copy-past from my screen to show what I see.

So you can easily see if you can reproduce the problems

I did with LO 5.1 beta 2
Comment 1 Jacques Guilleron 2015-12-05 17:14:38 UTC
Hello Pierre,

I reproduce with
LO 5.1.0.0.beta2 Build ID: 53054959a12edc6510f51b94ddc9b73d27aedaf6
Threads 2; Ver: Windows 6.1; Render: GL; Locale : fr-FR (fr_FR)

LO 5.1.0.0.alpha1+ Build ID: f6bc5b79c31225c02e9500d0ced4bd26f998f82b
Threads 2; Ver: Windows 6.1; Render: GL; Locale: fr-FR (fr_FR)
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-24_01:07:47

All issues vanish if I disable "Use OpenGL for all rendering (on restart)"

I don't reproduce with
LO 5.0.3.2 Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75, OpenGL abled or unabled.
I set Status to NEW, Keywords to regression.
@ Pierre: You don't have noticed your OS. Can you correct it, please?
Comment 2 V Stuart Foote 2015-12-05 20:08:43 UTC
Issues of screen clip pasted into slide two looks like a dupe of bug 95648 -- When OpenGL rendering is active-- Uniscribe/Graphite font has black blocks when text justified

In the Exo style for the ODP presentation.

Character used is "Linux Libertine G"

Paragraph is aligned "Justified" 

The only thing not 100% is if the OP was on a Windows build? @Pierre C please provide that confirmation.  Clip from the Help -> About LibreOffice dialog.

However, going ahead and setting as duplicate of tdf#95648

*** This bug has been marked as a duplicate of bug 95648 ***
Comment 3 Pierre C 2015-12-07 17:05:45 UTC
@V Stuart Foote
Yes, I'm using Windows 10 x64