Download it now!
Bug 96315 - Multiple graphics inside frame do not keep arrangement after re-opening document
Summary: Multiple graphics inside frame do not keep arrangement after re-opening document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-07 16:47 UTC by David
Modified: 2017-05-28 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
multiple overlapping graphics inside frame (65.97 KB, application/vnd.oasis.opendocument.text)
2015-12-07 16:47 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2015-12-07 16:47:20 UTC
Created attachment 121114 [details]
multiple overlapping graphics inside frame

When using multiple graphics inside a frame, the arrangement of the graphics does not stay the same after closing the document and re-opening when the graphics overlap.  This isn't a show-stopper bug, but it does require searching the document for such behavior before printing or exporting to pdf so that it can be corrected.  See attached document for example of bug.  In this example, the "no circle" symbol requires being brought to the front every time the document is opened so that it is on top of both of the other graphics.
Comment 1 Buovjaga 2015-12-10 09:46:59 UTC
It seems to be the same as bug 84127

*** This bug has been marked as a duplicate of bug 84127 ***
Comment 2 Luke 2016-01-07 23:23:16 UTC
This was marked a dupe of bug 84127, but that is a regression in the 4.2.x line. I can reproduce this issue with LibreOffice Version: 4.1.0.1 and AOO 3.4.1.
Comment 3 Buovjaga 2016-01-08 08:29:24 UTC
(In reply to Luke from comment #2)
> This was marked a dupe of bug 84127, but that is a regression in the 4.2.x
> line. I can reproduce this issue with LibreOffice Version: 4.1.0.1 and AOO
> 3.4.1.

Ok, maybe this is a dupe of bug 41006?
Comment 4 QA Administrators 2017-03-06 14:41:56 UTC Comment hidden (obsolete)
Comment 5 Luke 2017-03-09 23:09:37 UTC
Z order still lost after save and reopening with Version: 5.4.0.0.alpha0+
Build ID: 5b805de10a1b05647b616e726f0a8b88ff30ae77
Comment 6 David 2017-05-28 14:52:05 UTC
Fixing bug 107392, which seems like a duplicate from the description, did not fix this bug.
Comment 7 David 2017-05-28 15:14:38 UTC
My bad.  I updated the development version of LibreOffice but my links were still pointing to the old version.  The fix for bug 107392 does seem to have fixed this bug.
Comment 8 Buovjaga 2017-05-28 15:23:39 UTC
(In reply to David from comment #7)
> My bad.  I updated the development version of LibreOffice but my links were
> still pointing to the old version.  The fix for bug 107392 does seem to have
> fixed this bug.

Wow, that is excellent news. I guess we can keep this as FIXED separately as they were seen as such separate issues.