Bug 96327 - Start Center: "F" accelerator for "Remote Files" conflicts with "alt+F" accelerator for "File" menu
Summary: Start Center: "F" accelerator for "Remote Files" conflicts with "alt+F" accel...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-07 23:02 UTC by V Stuart Foote
Modified: 2016-10-25 19:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-12-07 23:02:31 UTC
The "F" mnemonic accelerator chosen for the new "Remote _File" feature on the StartCenter conflicts with the <Alt>+F shortcut on the main menu.

Suggest better UX if the accelerator in the StartCenter UI configuration file is changed to "E", i.e. to "R_emote File" in the startcenter.ui file.

=-ref-=
http://opengrok.libreoffice.org/xref/core/sfx2/uiconfig/ui/startcenter.ui
Comment 1 tommy27 2015-12-08 06:51:00 UTC
tested in recent LibO 5.2.0.0 alpha

I see no conflict since if you hit "F" it opens the remote files window while if you hit "alt+F" it opens the File menu

moreover I see that "e" is already assigned to Templates

am i missing something?
Comment 2 Buovjaga 2015-12-08 10:03:00 UTC
(In reply to tommy27 from comment #1)
> tested in recent LibO 5.2.0.0 alpha
> 
> I see no conflict since if you hit "F" it opens the remote files window
> while if you hit "alt+F" it opens the File menu
> 
> moreover I see that "e" is already assigned to Templates
> 
> am i missing something?

Both F and alt-F open Remote files for me.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)
Comment 3 tommy27 2015-12-08 12:16:55 UTC
you are right... probably I did some mistakes before but now I see the bug too under Win8.1 x64
Comment 4 Yousuf Philips (jay) (retired) 2015-12-08 12:56:07 UTC
(In reply to V Stuart Foote from comment #0)
> The "F" mnemonic accelerator chosen for the new "Remote _File" feature on
> the StartCenter conflicts with the <Alt>+F shortcut on the main menu.

Its a bug in the start center that Alt+F is opening remote files.

> Suggest better UX if the accelerator in the StartCenter UI configuration
> file is changed to "E", i.e. to "R_emote File" in the startcenter.ui file.

Like tommy mentioned, E is taken by T_emplates and the only letter in 'Remote Files' that isnt used in the menu bar and other buttons in 'S'. But similar to the discussion before between the Tools menu and Templates, i dont see a problem with the menu bar and buttons using the same accelerators as the menu bar is only accessible with Alt.
Comment 5 V Stuart Foote 2015-12-08 14:31:13 UTC
Sorry, sight garb on my part is suggesting "e" which we assigned to T_emplates rather than "T" which is a top level Short-cut assigned to the main menu.

While they are different assignments (accelerators vs. short-cut key) they have an impact on the user experience if they are not assigned uniquely.

We need *clarity* and preciseness in accelerator and short-cut behavior on the StartCenter because we do not translate some of the elements. And the .UI based StartCenter already has issues with OS/DE handling keyboard navigation.

That, coupled with Simon Long's rework for gtk3 support of hiding the accelerator and short-cut indicator underlines, makes inconsistency issues more troubling. 

So, here is an alternative, what about changing two?  And assigning from the English phoneme.

Remote Files gets the "e" -- R_emote

Templates gets the "p" -- Tem_plates 

The "m" already assigned to Math for the formula editor.

@Jay, in addition to deconflicting Tools and Template, we did similar for the two Help entries (see bug 80477).
Comment 6 Yousuf Philips (jay) (retired) 2015-12-09 10:57:34 UTC
Changing 'E' in Templates which was set since 4.2 would result in additional translation work for no real benefit. Changing 1 entry rather than 2 would always be the best solution.
Comment 7 Gabriele Ponzo 2016-01-29 13:33:48 UTC
I've moved accelerator from F to S as suggested.

Thanks to _david_ for pushing the patch.
Comment 8 Buovjaga 2016-01-29 13:43:19 UTC
(In reply to Gabriele Ponzo from comment #7)
> I've moved accelerator from F to S as suggested.
> 
> Thanks to _david_ for pushing the patch.

Ah, it is here: https://gerrit.libreoffice.org/#/c/21898/
Comment 9 Commit Notification 2016-02-01 17:58:48 UTC
Gabriele Ponzo committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43adbc8489cd724545a6cde72a8720a76ac554f0

tdf#96327: Fix accelerator for remote files

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Cor Nouws 2016-02-01 18:47:05 UTC
Thanks Gabriele :) ! This shortcut annoyed me for a long time already.
Comment 11 Gabriele Ponzo 2016-02-02 00:24:49 UTC
Glad to have been helpful with this very first patch.

Who should close this bug?
Comment 12 V Stuart Foote 2016-02-02 00:59:14 UTC
Closing. Thanks!
Comment 13 Commit Notification 2016-02-02 12:10:36 UTC
Gabriele Ponzo committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44c3447b9be9c8f70932cdbfc25e9b0961a3d0eb&h=libreoffice-5-1

tdf#96327: Fix accelerator for remote files

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 V Stuart Foote 2016-02-02 15:47:50 UTC
Now if only we could do something about bug 92516