Download it now!
Bug 96339 - Creating "sort list" with option Copy in options dialog, omits adding comma as separator
Summary: Creating "sort list" with option Copy in options dialog, omits adding comma a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Noel Grandin
URL:
Whiteboard: target:5.2.0 target:5.1.0.1
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-12-08 13:12 UTC by Cor Nouws
Modified: 2016-10-25 19:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test file for crating sort list (19.87 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2015-12-08 13:22 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-12-08 13:12:11 UTC
One can create "sort list" with tools > Options > Calc > Sort Lists.
One way is using the Copy button when wanted entries are selected in spreadsheet.

To reproduce:
1. Type the next list, each word in a cell
Apple
Pear
Mango
Melon
Grape

2. Select the list.

3. Open tools > Options > Calc > Sort Lists, click the Copy button

 > the new list is shown in Lists and Entries.

When you do this in 5.1.0beta1 there is no comma separator.
So all you have is the entry ApplePearMangoMelonGrape
As a consequence, the list is not effective.
( Type e.g. Apple. Select the cell. Drag with the block in the lower right corner of the cell. Pear, Mango etc. are not filled. 
Also using the sort list at the Options tab of the sort dialog, does not help.)

Try creating a list in e.g. 4.4.7.1 and there are comma separators.
And the list does work.

I will attach a simple test document,.
Comment 1 Cor Nouws 2015-12-08 13:22:54 UTC
Created attachment 121139 [details]
test file for crating sort list
Comment 2 m.a.riosv 2015-12-08 16:48:10 UTC
Hi Cor,
reproducible.
Win10x64
Version: 5.1.0.0.beta2 (x64)
Build ID: 53054959a12edc6510f51b94ddc9b73d27aedaf6
Threads 4; Ver: Windows 6.19; Render: default;
Comment 3 Cor Nouws 2015-12-08 16:50:42 UTC
Thanks Miguel!
Comment 4 m.a.riosv 2015-12-08 17:00:23 UTC
User interface English (USA), Locale settings Default Spanish.

Editing the list in SortList option, adding a comma for all entries except the last, makes the list running fine.
Comment 5 raal 2015-12-09 15:35:25 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one?
Thanks

b80c728eea56399ca5cdb73857871e861fc832b6 is the first bad commit
commit b80c728eea56399ca5cdb73857871e861fc832b6
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Nov 14 01:41:31 2015 -0800

    source sha:977220881cfffefb49843f27d3ab68f2de555469

    source sha:977220881cfffefb49843f27d3ab68f2de555469
    source sha:c6c8af5ef46e2178e4b9abcd95f76c8df2db2732
    source sha:b957190edfc40e1fea99e4781c95aea0bd6fce5e
    source sha:9b421ef6dee41c33d1a82fc8a8ec6983f13fe2a7
    source sha:5d201bc4909698d276cc4764017b15faa9b5b7be
    source sha:8e2f4c7817320354903d9d2c52d59403f37e22b5
    source sha:2083761d19c91dc875a69f049f53fe91e421a9f0
    source sha:b701bd8cbd46644e28d0dbcae94d5098b72036d8
    source sha:6b5e4c1f548f459e2d81963efdd4eb661de1fe89
    source sha:f6ef7e33b034d4ee5fb85ae4b72d8d255fbed2b6
    source sha:1c482cb54b4dab4c5b549ecd2395104f042e4101
    source sha:5f8aaeae51b46c59090227d60f39f98ebf0ef767
    source sha:4235138c2f16d60b84c1a9c9465c9af0e2a137d6
    source sha:12d51ad73c68ffe238dc2c28f9abd6b679dffb34
    source sha:f54a384f5ac16e969e8ecbf2821b89e0173c7403
    source sha:343ec4b7234f4eb9709f09d453131100d3283ddc
    source sha:280553e30f4ddc932838f98a9efaac03a988a0df
    source sha:601fd58cc3a4ce3a13bc0dad1cc16f0a841aa765
    source sha:e5e2f119eff6f57ad7abc70efd4986f8f8b3fc00
    source sha:f3ba19b37f212a5839a91223f77d501d79e2c4b5
    source sha:c2defd97cb60439fc25970c903e66fbecad148e5
    source sha:75aaa65a8f0f145657098278c3a7a3973b2c29df
    source sha:a029ab3d480c97313dc88dc6e1fbc0f3a900fb09
    source sha:2aacf6c2cd82322b953988ff30d3bc997ae76d7b
    source sha:ab3d557b48cacb30598c6b5ebb1cadece493fde8
    source sha:1740d0b2bec4c899af825739a8ca996785b5b525
    source sha:0f611e670a36d22c66d91ee309eccac1ea65e0e9
    source sha:9265f9bd35ff6ef0e4ab285dd9fecebce6976e8d
    source sha:83a58be116762abeab4ec3a90b8aafa076484b4a
    source sha:16877ccbd2dc227ab25f19914b9d453a082e405b
    source sha:33bf2449730c796a41a25f9287aa40e51c2bc464
    source sha:6618e503b3f6acf282c0c97150f591e643f8db8b
    source sha:6f6668c1f28ddb42b940c56f7fa24c37fd2e1850
    source sha:438a3f77e3814f90e2e3727e6d482d66e3259d36
    source sha:b3206e487403ab0da089010b8a56fa6b5d9edd56
Comment 6 Noel Grandin 2015-12-10 07:44:21 UTC
that's quite a range of commits. Could you narrow it down?
Comment 7 raal 2015-12-10 08:16:19 UTC
(In reply to Noel Grandin from comment #6)
> that's quite a range of commits. Could you narrow it down?

Unfortunately it's not possible. The bibisect repo is set on one commit per bibisect, yhis is because these commits left the tree not buildable, this is
what happen when commit that broke the build are pushed to master.
Comment 8 Noel Grandin 2015-12-11 11:59:35 UTC
I have isolated the bad commit to 2aacf6c2cd82322b953988ff30d3bc997ae76d7b 

Still working on figuring out why that causes a problem
Comment 9 Commit Notification 2015-12-12 04:53:01 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0bcef149ce3785306271fa06184eb62950b62087

tdf#96339 fix bug in sort list

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-12-12 05:47:42 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e8c433b34754490e1415e6b98d2a3c51c7e5dbab&h=libreoffice-5-1

tdf#96339 fix bug in sort list

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Cor Nouws 2015-12-12 17:52:05 UTC
Thanks Noel!
Comment 12 Robinson Tryon (qubit) 2015-12-17 10:53:29 UTC Comment hidden (obsolete)