Bug 96342 - LibreOffice crashed if I try to delete specific cell content every time
Summary: LibreOffice crashed if I try to delete specific cell content every time
Status: RESOLVED DUPLICATE of bug 99733
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-12-08 19:04 UTC by Ljiljan
Modified: 2016-05-26 15:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Working file (18.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-08 19:04 UTC, Ljiljan
Details
Gdbtrace from 5.0.3 (21.45 KB, text/plain)
2015-12-14 08:53 UTC, Buovjaga
Details
Example of deleting multiple cells (8.69 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-24 20:01 UTC, sandraborg86
Details
Crash log from OS X (82.62 KB, text/plain)
2016-05-24 20:10 UTC, Buovjaga
Details
gdbtrace (without symbols) (10.15 KB, text/x-log)
2016-05-24 20:13 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2015-12-08 19:04:05 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.73 Safari/537.36
Build Identifier: LibreOffice 5.0.3.2

LibreOffice crashed if I try to delete specific cell content every time. 



Reproducible: Always

Steps to Reproduce:
1. Open attached files
2. Select cells from D182 to I4.
3. Press Delete 
Actual Results:  
LibreOffice crashes

Expected Results:  
LibreOffice should not crash

[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Ljiljan 2015-12-08 19:04:25 UTC
Created attachment 121148 [details]
Working file
Comment 2 Buovjaga 2015-12-14 08:53:18 UTC
Created attachment 121288 [details]
Gdbtrace from 5.0.3

Repro crash on Ubuntu.
No crash on Win.

Ubuntu 15.10 64-bit 
Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1
Locale: en-US (en_US.UTF-8)

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 917d59a84124d1022bd1912874e7a53c674784f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-12_12:17:04
Locale: fi-FI (fi_FI)
Comment 3 Julien Nabet 2015-12-28 21:17:56 UTC
On pc Debian x86-64 with 5.0.4.2, I don't reproduce this but have a hang.
However, I don't reproduce this with master sources updated today.
I noticed this:
warn:sc.core:24968:1:sc/source/core/data/bcaslot.cxx:1161: ScBroadcastAreaSlotMachine::BulkBroadcastGroupAreas - pArea has no listeners and should had been removed already
This trace has been added to fix tdf#93388 (see http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d4edd7de2e67db5bd17e7a89e2496611ebcc165)
Comment 4 Ljiljan 2015-12-29 09:00:08 UTC
5.0.4.2. still reproducible (as you said, LO hang not crash).... but the only way to continue work in any LO app is to force close Calc.
Comment 5 Buovjaga 2015-12-29 14:26:57 UTC
(In reply to Ljiljan from comment #4)
> 5.0.4.2. still reproducible (as you said, LO hang not crash).... but the
> only way to continue work in any LO app is to force close Calc.

Maybe test with 5.1 RC1 and close as WORKSFORME, if the hang is gone?
Comment 6 Yogesh Desai 2016-04-15 10:42:18 UTC
Not able to reproduce with following setup.

I am using Cent-OS 7 with 64 bit version

Version: 5.2.0.0.alpha0+
Build ID: 2c93d340ae4e854b5c9d3aa8c38a8bba0ae6b74b
CPU Threads: 8; OS Version: Linux 3.10; UI Render: default; 
Locale: en-IN (en_IN.UTF-8)

I request others to please confirm it.

Thank you!
Comment 7 Julien Nabet 2016-04-15 10:54:41 UTC
Let's put this one to NEEDINFO since we're waiting a feedback of the reporter with a 5.1 version.
Comment 8 sandraborg86 2016-05-24 19:41:28 UTC
I have LibreOffice version 5.1.3.2 for Mac, OSX El capital 10.11.4 (macbook air mid 2013)

Every time I select multiple cells and press delete to clear them all, libre office crashes.
Comment 9 Julien Nabet 2016-05-24 20:00:47 UTC
sandraborg: version must correspond to the earliest one which one's can encounter the bug.
Since you reproduced this on MacOSX whereas reporter indicated Linux, it means we can put "All" for Hardware.
Anyway, as you may have seen, I put your useful information in Whiteboard.
Comment 10 sandraborg86 2016-05-24 20:01:25 UTC
Created attachment 125263 [details]
Example of deleting multiple cells

selecting all cells (C9 to J14) and press delete= program crashes
deleting only cells H9 to H12 = program does not crash
Comment 11 Buovjaga 2016-05-24 20:02:12 UTC
(In reply to sandraborg86 from comment #8)
> I have LibreOffice version 5.1.3.2 for Mac, OSX El capital 10.11.4 (macbook
> air mid 2013)
> 
> Every time I select multiple cells and press delete to clear them all, libre
> office crashes.

No crash for me.

It seems you have a problem that is specific to your system and it is in any case different from this bug. Please try https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

So I am not of the opinion that this is confirmed on OS X.

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
Locale: en-US (en.UTF-8)
Comment 12 Buovjaga 2016-05-24 20:10:32 UTC
Created attachment 125264 [details]
Crash log from OS X

I posted my previous comment before seeing the attachment 125263 [details]
I could reproduce the crash with it, but I don't know if it is the same.
If it is different, a new report should be opened.
Comment 13 Julien Nabet 2016-05-24 20:13:56 UTC
Created attachment 125265 [details]
gdbtrace (without symbols)

On pc Debian x86-64 with master sources updated today, I could open the file without crash or hang.
I just noticed these:
warn:sc.core:17083:1:sc/source/core/data/bcaslot.cxx:1139: ScBroadcastAreaSlotMachine::BulkBroadcastGroupAreas - pArea has no listeners and should had been removed already

However with LO Debian package 5.1.3.2, I had a crash (not a hang).

(there's no package libreoffice-dbg on Debian testing, that's why there's no symbol)
Comment 14 Ljiljan 2016-05-25 06:58:45 UTC
Selecting C19:J14, pressing Delete in LibreOffice 5.1.3.2. under Ubuntu 16.04 (both LibeOffice and Ubuntu are fresh installed from 24th April) with HARDWARE ACCELERATION ENABLED will cause LibreOffice to crash.

With HARDWARE ACCELRATION DISABLED it hangs out and you need to close it.
Comment 15 Buovjaga 2016-05-25 07:52:49 UTC
(In reply to Ljiljan from comment #14)
> Selecting C19:J14, pressing Delete in LibreOffice 5.1.3.2. under Ubuntu
> 16.04 (both LibeOffice and Ubuntu are fresh installed from 24th April) with
> HARDWARE ACCELERATION ENABLED will cause LibreOffice to crash.
> 
> With HARDWARE ACCELRATION DISABLED it hangs out and you need to close it.

In attachment 121148 [details] or attachment 125263 [details]? Let's keep this about the original issue.
Comment 16 Buovjaga 2016-05-25 18:38:52 UTC
Deleting cells from D182 to I4 in attachment 121148 [details] crashes on Linux.

Deleting cells from C9 to J14 in attachment 125263 [details] does NOT crash on Linux.

We have two different problems here, guys.

sandraborg: you should create a new report for your problem and tell about it here and I will come and confirm it.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 6c785f65ea5cc961c0a079455973f3086731b2c9
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on May 20th 2016

64-bit, KDE Plasma 5
Build ID: 5.1.3.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 17 Ljiljan 2016-05-26 09:02:01 UTC
I cannot repeat original problem on my installation (deleting the cells from D182 to I4), however deleting C19:J14 do cause crash as explained in my previous post.
Comment 18 Yogesh Desai 2016-05-26 09:43:53 UTC
I checked with following setup.

OS: Fedora 23

Version: 5.2.0.0.alpha1+
Build ID: f688acfdae00ebdd891737e533d54368810185e1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.utf8)

Case I(Original): Select D182 to I4 & Delete :=> LO crashes

Case II: Select C9 to J14 & Delete :=> LO Does not crashes

Case III: Select H9 to H12 & Delete :=> LO Does not crashes 

I would suggest that we should focus on First & Original Case which is Reproducible Always.

Awaiting response from others.
Thank you!
Comment 19 Caolán McNamara 2016-05-26 13:50:17 UTC

*** This bug has been marked as a duplicate of bug 99733 ***
Comment 20 Buovjaga 2016-05-26 15:33:43 UTC
(In reply to Buovjaga from comment #16)
> Deleting cells from D182 to I4 in attachment 121148 [details] crashes on
> Linux.

Thanks, Caolán. I retested with a build from today and no crash anymore.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 60041cb237ea73c2c1885dd6afd99d88780c2dfc
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on May 26th 2016