Bug 96389 - Default tab size wrong on pptx import
Summary: Default tab size wrong on pptx import
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.3
Keywords:
: 104909 148046 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-10 14:07 UTC by Armin Le Grand
Modified: 2022-05-04 10:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
testfile to demonstrate the bug (30.59 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-12-10 14:07 UTC, Armin Le Grand
Details
test compared MSO LO (73.07 KB, image/png)
2020-03-22 18:20 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Armin Le Grand 2015-12-10 14:07:11 UTC
Created attachment 121204 [details]
testfile to demonstrate the bug

To reproduce:
- Import the attached document
-> each letter should be left-bounded by one of the vertical ines

To fix:
- use tools/options/impress/general
- set tab stops to 2,54 (1 inch)
-> all looks good

The default TabStops are different, so when importing either
(a) the default has to be adapted
(b) TabStops as hard attributes have to be added

Where (a) has the problem that this will be then for all impress documents...
Comment 1 Samuel Mehrbrodt (allotropia) 2015-12-11 07:41:41 UTC
Confirmed with recent master.
Comment 2 QA Administrators 2017-01-03 19:49:06 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2019-12-03 14:52:11 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-03-22 18:20:57 UTC
Created attachment 158880 [details]
test compared MSO LO

As seen, was wrong in OO. Same from LO 3.3 to LO 7.0+.
Still fine if tab set from 1,25 cm to 1,54 cm. 

Content of xml - :
<a:r>
   <a:rPr lang="de-DE" dirty="0" smtClean="0"/>
   <a:t>A	b	c	d	e	f	g</a:t>
</a:r>
Comment 5 NISZ LibreOffice Team 2021-01-14 10:19:10 UTC
*** Bug 104909 has been marked as a duplicate of this bug. ***
Comment 6 Gabor Kelemen (allotropia) 2022-03-18 09:49:29 UTC
*** Bug 148046 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2022-03-25 07:26:38 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/362fb6c7b13d5506c6bd9d1b7f113ec45544809d

tdf#96389 Use default tab stop value of MSO for pptx import.

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-03-25 11:58:24 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/0d65d4c6b7272f4ca8e413e025db234e5c8c7722

tdf#96389 Use default tab stop value of MSO for pptx import.

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Buovjaga 2022-04-06 13:50:34 UTC
Can this be closed as fixed?
Comment 10 Timur 2022-04-06 14:37:14 UTC
Looks good.