Bug 96435 - FORMATTING: error bars disappear upon saving in .xlsx format
Summary: FORMATTING: error bars disappear upon saving in .xlsx format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 99203 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-12 06:11 UTC by Marisano James
Modified: 2019-02-18 14:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example Calc file in .ods format (15.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-12 06:11 UTC, Marisano James
Details
Example Calc document saved in .xlsx format (7.39 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-12-12 06:15 UTC, Marisano James
Details
Screenshot of the exported file to .xlsx by LO Master (114.81 KB, image/png)
2019-02-18 14:38 UTC, Balázs Varga
Details
Exported original file to .xlsx (7.68 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-18 14:41 UTC, Balázs Varga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marisano James 2015-12-12 06:11:45 UTC
Created attachment 121237 [details]
Example Calc file in .ods format

Description: After saving a Calc document in .xlsx format, closing, and then reopening it, the error bar line style is set to none, resulting in the error bars no longer being drawn. (They can still be accessed via the "Select Chart Element" drop down, however.)

Steps to reproduce:
1. Create a document with (y) error bars or open a .ods document with them.
2. Select "Save As" from the File menu, and save the file in .xlsx format.
3. Close the document.
4. Reopen the document in Calc.
5. The error bars are invisible!

Expected behavior: Error bars would be visible.

Current behavior: Error bars are not visible.


PS. I've attached an example file in .ods format which can be saved in .xlsx format, as well as an .xlsx version of the same document that already has been converted. As an extra added bonus, the converted file also does not show its Data Series chart columns for the same reason (i.e. their line style has been set to none).

PPS. I know there was a Mac OS bug (Bug 62312) with very similar symptoms that was ostensibly fixed, but here it is again (?) in Linux. I'm running version 5.0.3.2. I have no idea what the earliest release the bug appears in, but I'm pretty sure it also occurred under 4.3.x, which I was running before installing 5.0.
Comment 1 Marisano James 2015-12-12 06:15:07 UTC
Created attachment 121238 [details]
Example Calc document saved in .xlsx format
Comment 2 Marisano James 2015-12-12 06:25:43 UTC
Note that this is not an effect of the width of the error bar being set to the default value of "0.00" (which is also displayed in the error bar dialog box - before and after saving in .xlsx format).
Comment 3 m.a.riosv 2015-12-12 15:52:44 UTC
Hi @Marisano,

reproducible.
Win10x64

With 4.1.6 / 4.2.8.2 / 4.3.7.2 / 4.4.7.2 also the bars are lost.

With Version: 5.0.4.1 (x64) Build ID: 2def61bcbb29a7a8611b833682fe1291910b11ad, onl
Comment 4 rififi 2016-04-10 18:41:55 UTC
Hi,

Reproducible on Manjaro Linux, x86-64.
Version 5.1.1.3 (but the bug has been present for a long time).
Comment 5 raal 2016-04-11 11:28:05 UTC
*** Bug 99203 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2017-05-22 13:21:47 UTC Comment hidden (obsolete)
Comment 7 m.a.riosv 2017-05-22 15:37:11 UTC
Still.
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group
Comment 8 QA Administrators 2018-05-23 02:38:13 UTC Comment hidden (obsolete)
Comment 9 rififi 2018-05-23 17:32:17 UTC
Still present in 6.0.4.2.
Comment 10 Balázs Varga 2019-02-18 14:38:55 UTC
Created attachment 149370 [details]
Screenshot of the exported file to .xlsx by LO Master

Probably this patch could help here:

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b89f239aa9d3d4660380bbd0c893aecde0986032%5E%21

tdf#97575 Chart OOXML: Export ShapeProps of Error Bars

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Balázs Varga 2019-02-18 14:41:25 UTC
Created attachment 149371 [details]
Exported original file to .xlsx