Bug 96453 - FORMATTING: Removed Conditional Formatting comes back.
Summary: FORMATTING: Removed Conditional Formatting comes back.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.4
Keywords:
: 103315 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2015-12-13 06:25 UTC by mrelwood
Modified: 2017-01-31 11:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple Spreadsheet with two Conditional Formattings. (9.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-13 06:25 UTC, mrelwood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mrelwood 2015-12-13 06:25:43 UTC
Created attachment 121253 [details]
Simple Spreadsheet with two Conditional Formattings.

***** As a bug report this got "NOTABUG", so this is a feature request. *****

If one Conditional Formatting rule is removed, and then another rule opened for editing, the removed rule is back when the editor window for the another rule is closed.

NOTABUG was reasoned by needing to click "OK" for the changes to be permanent. The issue is that the window where the edits were made, was never closed, and the edits were never cancelled. Having to click "OK" and reopen the window after each edit is senseless.

Steps to reproduce:

1. Create two conditions in a LibreOffice Spreadsheet (Format > Conditional Formatting > Manage...).
2. Select one condition in the Manager, and click "Remove".
3. Double-click (or select and click "Edit...") the remaining condition. 
4. Just click "OK" or "Cancel" to close the opened editing window.

The first condition that was removed, has now magically raised from the dead. For removed rules to remain dead, the Manager window must be closed and reopened before editing the other rule.

This issue is not huge by itself, but as the Conditional Formatting range splitting bug requires constant housekeeping, this issue gets annoying pretty fast.
Comment 1 Alex Thurgood 2015-12-14 08:00:13 UTC
From a user perspective, having to click an extra button to validate the removal might indeed seem like a chore when there are many conditions to edit ==>> NEW
Comment 2 mrelwood 2015-12-14 11:38:28 UTC
To be more precise, it currently takes 3 clicks and some precise mouse movements to click "OK" and reopen the window for further editing.

I would suggest that the validating of the removal would still require the click of the "OK" button, but that the Manage window would keep it's edited state for as long as it is open. So that the user could remove and edit conditions for as long as is needed, and all the edits would be either cancelled or confirmed only when the window is closed. Currently the removals are cancelled when another window opens on top.
Comment 3 m.a.riosv 2015-12-15 01:15:01 UTC
Perhaps an "Apply" button could be fine.
Comment 4 Markus Mohrhard 2016-03-26 17:44:57 UTC
Obviously this is a bug and not a feature request.
Comment 5 Markus Mohrhard 2016-03-28 15:16:03 UTC
Looks like a regression from 2b5915da4 (which IMHO was a bad commit anyway).
Comment 6 Markus Mohrhard 2016-09-18 14:14:22 UTC
Fixed together with Bug 100793
Comment 7 Commit Notification 2016-09-19 10:12:13 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b8c22379e2eae74f7ed78326ab89483db5c6624

tdf#96453, tdf#100793 rework transfer of data between cond format dlgs

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-09-29 11:43:21 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56239a62557c413665b05b6f9692c48a455d4825

add test for tdf#96453 part 1

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-09-29 15:31:30 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a142d1dbdc33c9c4694e04f3b8b89848da47da6

add complete test for tdf#96453

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-10-13 16:03:14 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98b580b302267fb7c781e94ef6d175d696e9e848&h=libreoffice-5-2

tdf#96453, tdf#100793 rework transfer of data between cond format dlgs

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 m.a.riosv 2016-10-18 20:56:23 UTC
*** Bug 103315 has been marked as a duplicate of this bug. ***
Comment 12 Zineta 2017-01-30 11:50:58 UTC
Testing daily builds for 5.3.1, 5.4.0 :
applied on attachment 121253 [details] cells B1:B10 format conditions not editable
any more: Add,Edit,Remove buttons available but Add & Edit useless.
Insert new data in column C1:C10 creating Conditional format  it seems ok,
it is opened already in editing mode, it is all now in current window, no need  for Edit button.