Download it now!
Bug 96458 - Unicode ExtB+ chars are badly handled in Calc
Summary: Unicode ExtB+ chars are badly handled in Calc
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2015-12-13 16:09 UTC by Danny Lin
Modified: 2019-06-03 22:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The test .ods file (9.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-13 16:09 UTC, Danny Lin
Details
Fig 1. Badly displayed when exported to PDF (45.85 KB, image/jpeg)
2015-12-13 16:09 UTC, Danny Lin
Details
Fig 2. Badly displayed when saved as .xlsx or .xls (70.69 KB, image/jpeg)
2015-12-13 16:12 UTC, Danny Lin
Details
Fig 3. Badly displayed when saved as .html (19.31 KB, image/jpeg)
2015-12-13 16:13 UTC, Danny Lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Danny Lin 2015-12-13 16:09:09 UTC
Created attachment 121263 [details]
The test .ods file

Unicode ExtB+ chars are not well handled in Calc. 

The original text of test files is "大黃䗪蟲丸狐𧌒䒜𧀬". See attachments for detail.
Comment 1 Danny Lin 2015-12-13 16:09:34 UTC
Created attachment 121264 [details]
Fig 1. Badly displayed when exported to PDF
Comment 2 Danny Lin 2015-12-13 16:12:52 UTC
Created attachment 121265 [details]
Fig 2. Badly displayed when saved as .xlsx or .xls
Comment 3 Danny Lin 2015-12-13 16:13:35 UTC
Created attachment 121266 [details]
Fig 3. Badly displayed when saved as .html
Comment 4 Buovjaga 2015-12-16 11:14:29 UTC
I get the paste error, but they don't display correctly after save + reload.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 5 QA Administrators 2017-01-03 19:45:58 UTC Comment hidden (obsolete)
Comment 6 Danny Lin 2017-01-04 14:18:32 UTC
This bug still presents on LibreOffice 5.2.3.3/Windows 7 SP1!!!
Comment 7 QA Administrators 2018-12-22 03:53:11 UTC Comment hidden (obsolete)
Comment 8 Danny Lin 2018-12-22 14:04:40 UTC
The situation is even worse on Libre Office 6.1.3.2 (x64). When I attempt to read the test .ods file LO becomes non-responsive and crashes!!! Then I attempt to open a new file and paste "大黃䗪蟲丸狐𧌒䒜𧀬" in a field, LO also becomes non-responsive and crashes!!!
Comment 9 Buovjaga 2018-12-22 16:44:40 UTC
(In reply to Danny Lin from comment #8)
> The situation is even worse on Libre Office 6.1.3.2 (x64). When I attempt to
> read the test .ods file LO becomes non-responsive and crashes!!! Then I
> attempt to open a new file and paste "大黃䗪蟲丸狐𧌒䒜𧀬" in a field, LO also
> becomes non-responsive and crashes!!!

No such problem for me.

Btw. what is the font used in the original file? Does it only come with Windows?

Arch Linux 64-bit
Version: 6.1.3.2
Build ID: 6.1.3-2
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 10 Danny Lin 2018-12-25 14:29:43 UTC
(In reply to Buovjaga from comment #9)
> (In reply to Danny Lin from comment #8)
> > The situation is even worse on Libre Office 6.1.3.2 (x64). When I attempt to
> > read the test .ods file LO becomes non-responsive and crashes!!! Then I
> > attempt to open a new file and paste "大黃䗪蟲丸狐𧌒䒜𧀬" in a field, LO also
> > becomes non-responsive and crashes!!!
> 
> No such problem for me.
> 
> Btw. what is the font used in the original file? Does it only come with
> Windows?
> 
> Arch Linux 64-bit
> Version: 6.1.3.2
> Build ID: 6.1.3-2
> CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
> Locale: fi-FI (fi_FI); UI-Language: en-US
> Calc: threaded

Yes, as the "hardward" field stated, this issue happens on Windows. The font in the file is "新細明體" (which does not have the Ext-B chars), but LO shouldn't get crash due to unsuppported chars in the specified font.
Comment 11 Buovjaga 2018-12-25 14:56:29 UTC
(In reply to Danny Lin from comment #10)
> Yes, as the "hardward" field stated, this issue happens on Windows. The font
> in the file is "新細明體" (which does not have the Ext-B chars), but LO
> shouldn't get crash due to unsuppported chars in the specified font.

Yep, in my comment you can see I tested also on Windows. So is this font shipped with Chinese version of Windows only or can we download it somewhere for free?
Comment 12 Danny Lin 2018-12-25 14:59:05 UTC
(In reply to Buovjaga from comment #11)
> (In reply to Danny Lin from comment #10)
> > Yes, as the "hardward" field stated, this issue happens on Windows. The font
> > in the file is "新細明體" (which does not have the Ext-B chars), but LO
> > shouldn't get crash due to unsuppported chars in the specified font.
> 
> Yep, in my comment you can see I tested also on Windows. So is this font
> shipped with Chinese version of Windows only or can we download it somewhere
> for free?

It's a very widely used font provided in the Chinese version of Windows.
Comment 13 Mark Hung 2019-06-03 22:32:04 UTC
Hi,

I'm closing this issue because multiple test cases have been included in this issue. Each test case has its own test file and steps to reproduce. Reporting several test cases together makes it hard to communicate the status of the issue . I'm sure some of the test cases in this issue have been fixed. Please feel free to report each test case as a separate issue.


Thanks.