Download it now!
Bug 96459 - Unicode ExtB+ chars are badly handled in Impress
Summary: Unicode ExtB+ chars are badly handled in Impress
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2015-12-13 16:38 UTC by Danny Lin
Modified: 2019-06-03 22:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The demo .odp (12.34 KB, application/vnd.oasis.opendocument.presentation)
2015-12-13 16:38 UTC, Danny Lin
Details
Fig 1. Badly displayed when saved as .pptx or .ppt (58.83 KB, image/jpeg)
2015-12-13 16:40 UTC, Danny Lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Danny Lin 2015-12-13 16:38:58 UTC
Created attachment 121268 [details]
The demo .odp

Open a new impress file, input "大黃䗪蟲丸狐𧌒䒜𧀬".

1. They are not displayed correctly after pasted. But will be displayed normally after saving, closing, and reopening the file.

2. They are badly displayed when exported to .pdf

3. They are badly displayed when exported to .html

4. They are badly displayed when saved as .pptx or .ppt

5. The file would be unable to open when saved as .ppsx or .pps
Comment 1 Danny Lin 2015-12-13 16:40:01 UTC
Created attachment 121269 [details]
Fig 1. Badly displayed when saved as .pptx or .ppt
Comment 2 Buovjaga 2015-12-16 11:10:36 UTC
For me, they are displayed correctly after pasting.
They are displayed incorrectly when saving as pptx.
PDF is correctly displayed.
Image in html is displayed correctly.
I am able to open ppsx.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: fi-FI (fi_FI)
Comment 3 QA Administrators 2017-01-03 19:45:57 UTC Comment hidden (obsolete)
Comment 4 Danny Lin 2017-01-04 14:17:10 UTC
This bug still presents on LibreOffice 5.2.3.3/Windows 7 SP1!!!
Comment 5 QA Administrators 2018-12-22 03:53:15 UTC Comment hidden (obsolete)
Comment 6 Danny Lin 2018-12-22 14:08:21 UTC
The situation is even worse on Libre Office 6.1.3.2 (x64). When I attempt to read the demo.odp file LO becomes non-responsive and crashes!!! Then I attempt to open a new file and paste "大黃䗪蟲丸狐𧌒䒜𧀬" in, LO also becomes non-responsive and crashes!!!
Comment 7 Mark Hung 2019-06-03 22:36:00 UTC
Hi,

I'm closing this issue because multiple test cases have been included in this issue. Each test case has its own test file and steps to reproduce. Reporting several test cases together makes it hard to communicate the status of the issue . I'm sure some of the test cases in this issue have been fixed. Please feel free to report each test case as a separate issue.

Note:
If the issues are related to file format, then each of the file format owes its own test case.

Thanks.