Bug Hunting Session
Bug 96473 - Data -> Pivot Table -> Insert (No option to insert)
Summary: Data -> Pivot Table -> Insert (No option to insert)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96552 97408 (view as bug list)
Depends on:
Blocks: Calc-Menus
  Show dependency treegraph
 
Reported: 2015-12-14 04:42 UTC by Joel Madero
Modified: 2016-08-06 20:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2015-12-14 04:42:06 UTC
Bodhi Moksha
LibreOffice: Version: 5.2.0.0.alpha0+
Build ID: 5df326438fd3a5613a52b4de1935426911ff1301

1. Data -> Pivot Table

Observed: no option to actually insert a pivot table

Maybe this was intentional? I see the option in insert but splitting the pivot table functions seems weird.

Probably will be closed but I figured I'd say that as a user who frequently uses pivot tables - seems like a strange decision.
Comment 1 Maxim Monastirsky 2015-12-16 22:14:07 UTC
*** Bug 96552 has been marked as a duplicate of this bug. ***
Comment 2 Maxim Monastirsky 2015-12-16 22:17:29 UTC
This was discussed previously in Bug 91820.
Comment 3 Joel Madero 2015-12-16 22:28:59 UTC
Thanks for that bug # - I commented over there. As I said over there, I don't have the energy, time, interest in debating endlessly about these massive changes to UI/UX/Design so I put my thoughts over there and the team can take those thoughts or leave them. What I can say is that as an anecdotal point, for someone who does in fact use LibreOffice daily for real work - and who uses Spreadsheets often for real tasks - the mass changes have left me entirely confused so I'm using an older version instead of doing work on dailies where I could potentially be finding bugs and reporting them...I just can't have these massive interruptions to my workflows due to complete reworks of toolbars/context menus/ and top menus....

again just anecdotal experience, the doers as always get to decide, just giving my input as a user of the product.
Comment 4 Maxim Monastirsky 2016-01-28 10:12:47 UTC
*** Bug 97408 has been marked as a duplicate of this bug. ***
Comment 5 Heiko Tietze 2016-01-28 10:28:17 UTC
The reasons for changes of the menu structure are published in [1]. We want to go with the modifications for now, and keep them as long as there are not much more complaints. If you want to restore the old position of menu items you may customize the menu bar. Sorry for the inconvenience.

[1] https://design.blog.documentfoundation.org/2016/01/22/way-down-in-the-libreoffice-menus/
Comment 6 Yousuf Philips (jay) (retired) 2016-01-28 11:05:22 UTC
From my comment in bug 97408.

... When you insert a chart you goto Insert > Chart, but if you want to edit it you goto Edit > Object > Edit. Same goes for images as you Insert > Image and then modify it with Format > Image > Properties. I'm all for grouping related functions all in one place, but its important to have all insert related functions in the Insert menu.
Comment 7 Cor Nouws 2016-08-06 20:32:42 UTC
(there will be an extra menu entry in the Data menu. See https://bugs.documentfoundation.org/show_bug.cgi?id=91820#c54 )