Bug 96490 - Accessible object:children-changed events not emitted when paragraphs are created, destroyed, or exposed
Summary: Accessible object:children-changed events not emitted when paragraphs are cre...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2015-12-14 18:33 UTC by Joanmarie Diggs
Modified: 2017-05-30 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs 2015-12-14 18:33:52 UTC
Steps to reproduce:
1. Launch LibreOffice Writer
2. Launch Accerciser and enable monitoring for LO children-changed events
3. Create several new paragraphs
4. Delete the paragraphs

Expected results: object:children-changed events would be logged by Accerciser.

Actual results: No object:children-changed events are logged by Accerciser.

In addition: Currently LO Writer exposes only on-screen paragraphs to ATs. As a result, when switching pages, the accessible tree is updated so that the document's children are the visible paragraphs. In other words, children are being added and removed. However, there are no object:children-changed events seen as a result.
Comment 1 Buovjaga 2016-05-06 10:54:28 UTC
In Accerciser, I selected soffice and then in Event monitor, radio button Selected application. Under Object, I ticked children-changed.

I do not reproduce the problem. I do get log events for children changed.

Please retest.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 540fee2dc7553152914f7f1d8a41921e765087ef
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 30th 2016
Comment 2 Joanmarie Diggs 2016-05-06 15:28:11 UTC
I'm doing what you're doing. And I continue to not see children-changed events. I tried with both 5.1.3.1-2.fc24 and 5.2.0.0.alpha1.

Mind you I get children-changed events from soffice. For instance, if I open a menu. But what I am not getting is children-changed events when I type text and press return (creating new accessible paragraph objects).
Comment 3 Buovjaga 2016-05-07 10:57:55 UTC
I tried it again and I guess I was confused.
Comment 4 QA Administrators 2017-05-22 13:40:52 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.2.7 or 5.3.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170522
Comment 5 Alex ARNAUD 2017-05-30 14:52:43 UTC
Dear all,

I always can reproduce this issue on LibreOfficeDev 5.5 of 2017-05-28.

Best regards.