Bug Hunting Session
Bug 96504 - PRINTING - picto controls are not printed
Summary: PRINTING - picto controls are not printed
Status: RESOLVED DUPLICATE of bug 89866
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-12-15 12:04 UTC by guillaume.leprovost
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with this bug (870.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-15 12:04 UTC, guillaume.leprovost
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guillaume.leprovost 2015-12-15 12:04:05 UTC
Created attachment 121314 [details]
Sample file with this bug

Picto controls are not printed since version 4.3

when i try to print this attached file, picture is not printed.
Comment 1 Buovjaga 2015-12-21 18:10:34 UTC
Yep, it works ok in 3.5.
Can already be seen in the print preview.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: fi-FI (fi_FI)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 Commit Notification 2016-04-27 16:51:31 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef52ce82bf55b37279e344ea5fef67b4277fb009

tdf#89866 tdf#96504 vcl: fix printing of form controls with images

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2016-04-27 16:51:57 UTC

*** This bug has been marked as a duplicate of bug 89866 ***
Comment 4 Commit Notification 2016-04-28 06:50:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b63c3d9bd9e616a7d38df6f12226cc3b5fd65c2d&h=libreoffice-5-1

tdf#89866 tdf#96504 vcl: fix printing of form controls with images

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.