Bug 96527 - FILEOPEN PPTX gradient not smooth
Summary: FILEOPEN PPTX gradient not smooth
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: OOXML-Object-Fill PPTX
  Show dependency treegraph
 
Reported: 2015-12-15 21:53 UTC by Ari Latvala
Modified: 2019-01-28 00:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PPTX slide with bad gradient colour (990.97 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-12-15 21:53 UTC, Ari Latvala
Details
JPG showing differences (110.80 KB, image/jpeg)
2015-12-15 21:56 UTC, Ari Latvala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2015-12-15 21:53:26 UTC
Created attachment 121328 [details]
PPTX slide with bad gradient colour

Among other problems on this slide the gradient backround is anything but smooth.
Comment 1 Ari Latvala 2015-12-15 21:56:55 UTC
Created attachment 121329 [details]
JPG showing differences
Comment 2 Ari Latvala 2015-12-15 21:57:32 UTC
Running LibreOffice 5.0.4.2 on Windows 7 64-bit
Comment 3 Buovjaga 2015-12-21 18:22:16 UTC
(In reply to Ari Latvala from comment #1)
> Created attachment 121329 [details]
> JPG showing differences

So the left pic is MSO I guess

But yeah I confirmed with PPT viewer.

In LibO the gradient area goes beyond the right border of the box. The gradient stops are too abrupt.

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: fi-FI (fi_FI)
Comment 4 Ari Latvala 2016-02-13 23:46:23 UTC
Problem still on LO 5.1.0.3 on Windows 7 64-bit
Comment 5 Ari Latvala 2016-03-02 22:19:29 UTC
(In reply to Ari Latvala from comment #4)
> Problem still on LO 5.1.0.3 on Windows 7 64-bit

And still the same on LO 5.2 nightly 2.3.2016 on Windows 7 SP1 64-bit.
Comment 6 Ari Latvala 2016-03-14 20:59:25 UTC
And also the latest LO 5.1.1.3 on Windows 7 SP1 64-bit shows really ugly gradients on show mode.
Comment 7 Ari Latvala 2016-06-02 20:22:27 UTC
Problem still there on the latest LO 5.2 Beta 1 for Windows 7 SP1 64-bit, especially on presentation mode.
Comment 8 Ari Latvala 2017-05-29 20:35:31 UTC
Still no change to this on LO 5.3.3, having these two gradient fills lapping each other and higher but narrower having frame with gradient color on the original file looks just really awful on Impress, when compared to MS PowerPoint. Both the animation and endresult are just unacceptable.
Comment 9 QA Administrators 2018-10-22 02:49:20 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2018-10-22 07:12:07 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: cec31fdedd7c94f4ebf903a66456a75867db22b0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-21_22:54:44
Locale: ru-RU (ru_RU); Calc: threaded