Bug Hunting Session
Bug 96591 - Formulas changed by adding sheet name before cell reference
Summary: Formulas changed by adding sheet name before cell reference
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-19 08:35 UTC by Eldar
Modified: 2018-02-13 15:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File with the bug (72.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-31 13:12 UTC, Migrec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eldar 2015-12-19 08:35:47 UTC
After updating from 5.0.3.2 to 5.1.0.1, all formulas changed by adding sheet name before cell reference. For example formula "=A1+B1" changed to "=Sheet1!A1 + Sheet1!B1".
Comment 1 Eldar 2015-12-19 09:08:08 UTC
Additionally, some formatting styles are broken in cells.

I suspect that it happened only on ODS files that was converted from XLSX files.
Comment 2 raal 2015-12-19 15:07:07 UTC Comment hidden (obsolete)
Comment 3 Eldar 2015-12-20 07:59:42 UTC
Unfortunately I can't reproduce it now, because I saved document with new version of LO. But I'm sure that formulas haven't Sheet names before cell references when I was opened and used it with LO 5.0.3.
Comment 4 Mateusz Konieczny 2016-02-24 15:31:20 UTC
I noticed it happening in my document, unfortunately I was unable to pinpoint (so far) when it happens. I keeps happening from time to time - maybe it happens on Calc updates?
Comment 5 Mateusz Konieczny 2016-02-24 15:32:00 UTC
For example it happened during using

Version: 5.1.0.3
Build ID: 1:5.1.0~rc3-0ubuntu1~trusty0
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: pl-PL (en_US.UTF-8)

maybe on upgrade from earlier version?
Comment 6 Mateusz Konieczny 2016-02-24 15:32:26 UTC
How can I check whatever my file was in the past a XLSX file?
Comment 7 Migrec 2016-05-31 13:12:18 UTC
Created attachment 125418 [details]
File with the bug
Comment 8 Eike Rathke 2016-07-22 13:31:21 UTC
There was such bug adding the sheet name to each reference but it's long fixed. Once stored to file there's nothing we could do in more recent release to remove such because the user could had added them on purpose.
Comment 9 carles 2018-02-13 15:40:15 UTC
I'm sorry, I think the problem is not due to a change of version.

I don't know how, obviously, and I don't kwon when, but sometimes when I reopen a file the formulas have changed by adding the sheet name before any cell reference.

I reproduced the problem many times during my life, in many Libre Office versions.
Currently, I'm using 5.1.6.2 in Ubuntu 16.04.3 but the problem also happened to me under Windows in many versions.

And this problem happens to me suddenly and twice a month at least (every day I work with many spreadsheet files)
It seems a silly question, but when happens, the reading and tracking of the formulas becomes very complicated.


My "solution" is always find the name of sheet and replace by nothing but when the file has many sheets it's heavy and annoying. Quite annoying, certainly.

I will appreciate reopen the bug in order to find a final solution.

Thank you.