Download it now!
Bug 96596 - Sidebar control element can't be removed while a sidebar deck is visible
Summary: Sidebar control element can't be removed while a sidebar deck is visible
Status: RESOLVED DUPLICATE of bug 90843
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-19 14:26 UTC by Jaap van de Putte
Modified: 2015-12-19 22:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap van de Putte 2015-12-19 14:26:07 UTC
I don't need the sidebar, so I choose in the sidebar for "Close sidebar". But every time I switch the styles on and off, the sidebar pops up. And it is extremely irritating that it keeps popping up every time I turn the styles on and off.
Comment 1 Buovjaga 2015-12-19 15:08:12 UTC
Why not undock the sidebar then? That way it will be like the old floating style window whenever you press F11. Click the top icon in the right-side vertical bar and select Undock. You can dock it from the same button later, if you change your mind.

Set to NEEDINFO.
Change back to UNCONFIRMED, if you are not happy with this. Change to RESOLVED INVALID, if you are satisfied with this method.
Comment 2 Jaap van de Putte 2015-12-19 15:13:02 UTC
I like to lock the style panel, otherwise it is floating around and I want it to stick on the right site. The problem is: when it is locked I can switch the styles off, but than immediatly the sidebar installs itself again on the right site. Pressing F11 (or on the Mac cdm-T) does not remove the sidebar. You have to manually go the bar and click on the button to remove it.
Comment 3 Buovjaga 2015-12-19 18:28:09 UTC
You say you don't need the sidebar, yet in reality you use it all the time. When the window is docked, it lives in the sidebar.
Apparently you would like to get rid of the narrow sidebar control element in the right side.

I will relay this to the design team, but I imagine they will not be too keen on the idea..
Comment 4 Jaap van de Putte 2015-12-19 19:08:23 UTC
Hi Beluga,

Thanks for your reply. You wrote:
'You say you don't need the sidebar, yet in reality you use it all the time. When the window is docked, it lives in the sidebar.
Apparently you would like to get rid of the narrow sidebar control element in the right side.'

If you have a 13# screen even a small sidebar is a waste of space if you don't need it. The point is that I as a user cannot decide to have it or have it not, in the same way as I can choose to have the style panel or the navigation panel. I'm going to look for downgrading LO for it is really annoying. I hope other people think the same and will vote for a change.
Comment 5 Buovjaga 2015-12-19 20:44:44 UTC

*** This bug has been marked as a duplicate of bug 90843 ***
Comment 6 Heiko Tietze 2015-12-19 22:22:31 UTC
You don't need to downgrade, just wait for the next update. It will give you access to the styles from the main menu. Hope that helps since Styles and Formatting (F11) is part of the sidebar and will not get a separate floating control, as Beluga said.
However you are right, there is an inconsistency with sidebar on/off and styles. But I'd rather remove the menu entry since the user can switch between styles using the toolbar.