Bug Hunting Session
Bug 96622 - FILEOPEN: DOCX Image may seem to be at wrong position because LO shows it's part that's outside of printable area
Summary: FILEOPEN: DOCX Image may seem to be at wrong position because LO shows it's p...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Images
  Show dependency treegraph
 
Reported: 2015-12-20 13:31 UTC by Dennis Roczek
Modified: 2018-01-12 08:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document (16.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-12-20 13:31 UTC, Dennis Roczek
Details
MSO2013 converted document (removing the "compatibility" message in Word) (16.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-12-20 13:32 UTC, Dennis Roczek
Details
MSO2013 converted document to ODF (9.62 KB, application/vnd.oasis.opendocument.text)
2015-12-20 14:21 UTC, Dennis Roczek
Details
printscreen from Word 2010 (14.38 KB, image/png)
2015-12-30 11:29 UTC, raal
Details
Example compared in MSO and LO (56.86 KB, image/jpeg)
2018-01-12 08:44 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2015-12-20 13:31:04 UTC
Created attachment 121437 [details]
Example document

Version: 5.0.4.1 (x64)
Build-ID: 2def61bcbb29a7a8611b833682fe1291910b11ad
Gebietsschema: de-DE (de_DE)
Windows 10 x64 Pro
LibO 32bit

This file is a mostly minimized document from a real life example. Sadly the image at the right upper corner is half way out of the printable area. :-(

Same problem occurs with a Word 2013 converted file (so removing the compatibility message) which will be attached in a few minutes.
Comment 1 Dennis Roczek 2015-12-20 13:32:00 UTC
Created attachment 121438 [details]
MSO2013 converted document (removing the "compatibility" message in Word)
Comment 2 Dennis Roczek 2015-12-20 14:21:32 UTC
Created attachment 121440 [details]
MSO2013 converted document to ODF

Sadly, when converting the original document with MSO2013 to odf the problems are not less... :-(
Comment 3 Buovjaga 2015-12-26 16:03:17 UTC
Confirmed.

In 3.5 it is inside the first cell (correct?).

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a4764cfa80270f973da5861d0ddc28298bf16f4d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-24_22:45:12
Locale: fi-FI (fi_FI)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 4 raal 2015-12-30 11:29:34 UTC
Created attachment 121633 [details]
printscreen from Word 2010
Comment 5 raal 2015-12-30 11:38:36 UTC
(In reply to Beluga from comment #3)
> Confirmed.
> 
> In 3.5 it is inside the first cell (correct?).
> 
Hi Beluga, tested with LO 4.0.0.3 and image is inside first cell. Please take a look at the printscreen and compare with 3.5, I mean this is not regression.
Comment 6 QA Administrators 2017-12-10 16:41:35 UTC Comment hidden (obsolete)
Comment 7 Dennis Roczek 2017-12-30 03:31:25 UTC
still repro with 
Version: 5.4.2.2 (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group

(uff I have again to update1; I do need to test the autoupdater now!)
Comment 8 Timur 2018-01-12 08:44:10 UTC
Created attachment 139059 [details]
Example compared in MSO and LO

(In reply to Dennis Roczek from comment #0)
> image at the right upper corner is half way out of the printable area. :-(

I don't know how this was confirmed. 
Image was at wrong position up to 4.3.x but from 4.4.0 it's correct. 
Preview looks different because image part outside of printable area is show in LO and not in MSO. But they are the same size: 3,25x4,65.
I attach comparison which shows that inside printable area it looks the same. And PDF export is also the same. 
So this bug is WFM and I'll close so. If you don't agree, feel free to check and explain. 

I also don't know why LO shows content outside of printable area and MSO doesn't in Print Layout mode. But I guess it's better to have this visible. And this bug is not about that general question, so I think it doesn't deserve to be discussed here. 

Note: There's something I also don't understand about this table: column widths in MSO are different than LO. But it still previews the same.