Bug Hunting Session
Bug 96705 - Change of dialogue Tools-Customize
Summary: Change of dialogue Tools-Customize
Status: RESOLVED DUPLICATE of bug 88896
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2015-12-24 08:21 UTC by Roman Kuznetsov
Modified: 2016-10-15 13:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Mockup Keyboard tab in dialogue Customize (55.80 KB, image/png)
2015-12-24 08:21 UTC, Roman Kuznetsov
Details
Mockup Menus tab in dialogue Customize (50.09 KB, image/png)
2015-12-25 07:39 UTC, Roman Kuznetsov
Details
Mockup Toolbars tab in dialogue Customize (47.66 KB, image/png)
2015-12-25 13:16 UTC, Roman Kuznetsov
Details
Mockup Events tab in dialogue Customize (41.78 KB, image/png)
2015-12-25 13:27 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-12-24 08:21:26 UTC
Created attachment 121527 [details]
Mockup Keyboard tab in dialogue Customize

because of the proliferation of widescreen displays 16: 9, I propose to change the Keyboard tab in the Customize dialog box. (see attachment)
Comment 1 V Stuart Foote 2015-12-24 18:51:30 UTC
@kompilainenn, *

While this one Tab on the Customize dialog would benefit, not clear that the other three Tabs of dialog gain anything by changing the ratio of the frame.

I do like the addition of "Search function" and "Search shortcut", but those could be incorporated using the existing layout ratio inserting it between the "Shortcut Keys" and "Functions"

If this were to be reworked, believe the entire dialog would need to be adjusted. 

Mockups, for the other tabs at 16:9?
Comment 2 Roman Kuznetsov 2015-12-24 19:00:31 UTC
(In reply to V Stuart Foote from comment #1)
> @kompilainenn, *
> 
> While this one Tab on the Customize dialog would benefit, not clear that the
> other three Tabs of dialog gain anything by changing the ratio of the frame.
> 
> If this were to be reworked, believe the entire dialog would need to be
> adjusted. 
> 
> Mockups, for the other tabs at 16:9?

I think above this. in a few days will draw the rest of the tab =)
Comment 3 Roman Kuznetsov 2015-12-25 07:39:56 UTC
Created attachment 121539 [details]
Mockup Menus tab in dialogue Customize
Comment 4 Roman Kuznetsov 2015-12-25 13:16:08 UTC
Created attachment 121543 [details]
Mockup Toolbars tab in dialogue Customize
Comment 5 Roman Kuznetsov 2015-12-25 13:27:20 UTC
Created attachment 121544 [details]
Mockup Events tab in dialogue Customize
Comment 6 Roman Kuznetsov 2015-12-25 13:43:59 UTC
(In reply to V Stuart Foote from comment #1)
> @kompilainenn, *
 
> Mockups, for the other tabs at 16:9?

done
Comment 7 Heiko Tietze 2015-12-27 09:52:36 UTC
Some time ago I prepared a couple of mockups, most likely I wouldn't do the same today. http://user-prompt.com/de/how-to-make-libreoffice-customization-usable/

Regarding your ideas I suggest to give clues about the interaction, e.g. the category list is a filter for the functions list, or assigned and available shortcuts are linked lists (you move items from one list to the other). Could be done by the placement of controls or by having the interaction controls nearby where it has an impact.

Anyway, I agree that we need to improve the customization dialog. At least when we get the enhanced toolbar or when the individualization of the sidebar will be possible.
Comment 8 Roman Kuznetsov 2015-12-27 10:03:11 UTC
(In reply to Heiko Tietze from comment #7)

> http://user-prompt.com/de/how-to-make-libreoffice-customization-usable/

I saw this post while looking for suggestions for changes in interface libreoffice
Comment 9 Robinson Tryon (qubit) 2016-08-25 05:39:21 UTC Comment hidden (obsolete)
Comment 10 Yousuf Philips (jay) (retired) 2016-10-15 13:42:13 UTC
Closing this as a duplicate of Heiko's bug report. Will add kompilainenn's mockup to that report

*** This bug has been marked as a duplicate of bug 88896 ***