Bug 96716 - Custom Shortcut Keys not working consistently
Summary: Custom Shortcut Keys not working consistently
Status: RESOLVED DUPLICATE of bug 97908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-12-25 01:16 UTC by liquidfractal
Modified: 2016-04-16 16:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description liquidfractal 2015-12-25 01:16:17 UTC
Before upgrading to LO 5.0.4.2 I had created a custom Shortcut key where Ctrl+Alt+F would insert a Foot/Endnote.  Now that I've upgraded, I notice that it still works but seemingly ONLY with the left Alt key.  Simply:

LEFT Ctrl + LEFT Alt + F = works
RIGHT Ctrl + LEFT Alt + F = works

But no combination with the right-hand Alt key will bring up the footnote menu.  Previously, any combination of Ctrl+Alt+F worked just fine.
Comment 1 Buovjaga 2015-12-27 17:20:24 UTC
Repro.

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a4764cfa80270f973da5861d0ddc28298bf16f4d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-24_22:45:12
Locale: fi-FI (fi_FI)
Comment 2 raal 2015-12-31 09:48:09 UTC
tested with CTRL+ALT+P (CTRL+ALT+F insert "[" in my version)
left CTRL+left ALT+P works OK
left CTRL+right ALT+P doesn't work 

This seems to have begun at the below commit.
Adding Cc: to Juergen Funk ; Could you possibly take a look at this one? Thanks

2a3691801f605674bb3e0b5996c12f869da32009 is the first bad commit
commit 2a3691801f605674bb3e0b5996c12f869da32009
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Nov 13 18:19:20 2015 -0800

    source sha:3ac9942c624cb627c8b09122498b45b05cf455f6

    source sha:3ac9942c624cb627c8b09122498b45b05cf455f6

:040000 040000 692e901c8bad3d84a49bf2776b14158cec8c2195 16a62145b6326a7fcc8e483ef7b9a316ab29b617 M      instdir

author	Juergen Funk <juergen.funk_ml@cib.de>	2015-11-12 09:50:59 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-11-12 14:14:32 (GMT)
commit	3ac9942c624cb627c8b09122498b45b05cf455f6 (patch)
tdf#95761 All Hotkeys with CTRL+ALT+ not worked
Comment 3 Juergen Funk (CIB) 2016-01-11 09:52:32 UTC
Hi raal,

i would look to 2a3691801f605674bb3e0b5996c12f869da32009 but is not valid?!

But the problem is on the german-keyboard it is diffrent between the left-ALT and the right-ALT, the right-ALT is called "ALTGR" and send (under windows) automatically "ALT-CTRL", an for my patch that was always masked out (only under windows), my patch make now a diffrent bwetween the right and left ALT.

Here i have try to change https://bugs.documentfoundation.org/show_bug.cgi?id=95635 and i have try to descript a little bit the problem (sorry for my bad english)

But i think we must refactor the Hot-Key-Handling, at the moment it not work properly for the any language-keyboards, and OS, but for the right Chars it works, but not for the Hot-Keys
Comment 4 raal 2016-01-11 10:27:08 UTC
(In reply to Juergen Funk from comment #3)
> Hi raal,
> 
> i would look to 2a3691801f605674bb3e0b5996c12f869da32009 but is not valid?!
> 
You have to use this number of commit>  source sha:3ac9942c624cb627c8b09122498b45b05cf455f6

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ac9942c624cb627c8b09122498b45b05cf455f6

Thanks
Comment 5 Björn Michaelsen 2016-04-15 13:40:45 UTC
@Juergen: As per bug 95761 is this "works as designed" and should be closed "WONTFIX"?
Comment 6 Björn Michaelsen 2016-04-16 16:12:44 UTC

*** This bug has been marked as a duplicate of bug 97908 ***