Bug 96728 - After upgrading to LO 5.1.0.1 field entries selected from a drop-down list are not updated
Summary: After upgrading to LO 5.1.0.1 field entries selected from a drop-down list ar...
Status: RESOLVED DUPLICATE of bug 96119
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-26 16:33 UTC by A (Andy)
Modified: 2015-12-27 01:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2015-12-26 16:33:42 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build Identifier: LibreOffice 5.1.0.1

After upgrading from LO 5.0.3.2 to LO 5.1.0.1 field entries selected from a drop-down list are not updated.

Reproducible: Always

Steps to Reproduce:
1. Go to TOOLS -> OPTIONS -> section LANGUAGE SETTINGS -> subsection LANGUAGES
2. For the field "User Interface" select another language from the drop-down list
Actual Results:  
The User Interface fields is still selected and shows not the new selected language, but still the old language.  If you close the dialog box with OK then the UI language will be changed (with a restart of LO).  If you open the Options dialog box again then the new selected entry (language) will be shown.

This bug happens for all entries in the Option dialog box.

Expected Results:  
The User Interface field should show the new selected entry (language).

[Information automatically included from LibreOffice]
Locale: en-GB
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 A (Andy) 2015-12-26 16:40:25 UTC
Remark: I recognised right now that this happens not only in the Options dialog box.  This issue seems to happen in any drop-down fields and dialog boxes.
Comment 2 A (Andy) 2015-12-26 16:49:26 UTC
After further testing it gets even worse.  

If I open CALC and go to FORMAT -> CELLS -> tab NUMBERS -> Category = CURRENCY and open the drop-down list in Format to select another currency I do not see the new selected currency, but it is also not changed and it closes the drop-down list immediately if I try to use the ruler on the right to scroll the drop-down list.
Comment 3 m.a.riosv 2015-12-26 17:53:44 UTC
I think a duplicate, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 96119 ***
Comment 4 A (Andy) 2015-12-26 18:10:54 UTC
(In reply to m.a.riosv from comment #3)
> I think a duplicate, please if you are not agree reopen it.
> 
> *** This bug has been marked as a duplicate of bug 96119 ***

m.a.riosv, thank you very much for your reply.  I am not yet sure if this is a full duplicate.  Maybe this is linked to other issue.  But in my case for the languages it was possible to select another language, but it was only not shown in the field, only after reopening the dialog box.  But maybe my issue will be solved with the other one and it could be tested again later with the next LO release with the patch and we wait and will see, whether we have to reopen my bug report.
Comment 5 m.a.riosv 2015-12-27 01:52:06 UTC
Hi @Andy, I think that's the bug.

Seems solved now for:
Version: 5.1.0.1.0+ Build ID: 756e103214c3c74c2af7e0da836b568259f81226
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1, Time: 2015-12-19_00:30:14