Download it now!
Bug 96746 - No Basic Help
Summary: No Basic Help
Status: RESOLVED DUPLICATE of bug 96855
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-28 14:24 UTC by tim
Modified: 2016-01-06 20:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2015-12-28 14:24:34 UTC
With this release (from 5.0.3.2) I've lost the BASIC help.  The other Helps are all there.

I'm using 5.0.4.2 Build ID: 1:5.0.4~rc2-0ubuntu1~trusty1 Locale: en-GB (en_GB.UTF-8)

If this isn't also true for other platforms or O/Ss I'll raise it with the Ubuntu team instead.
Comment 1 tim 2015-12-28 20:20:07 UTC
I just tried on Windows 7.  The Basic Help is also missing there in 5.0.4.2 GB Help.

I use this a lot.  

Help!
Comment 2 Buovjaga 2015-12-29 19:04:07 UTC
I don't know, how to run help for languages I don't have installed.

I installed the en-GB help and the folder contains all the sbasic files cfg, db, ht, jar, key, tree.
Does it contain them for you as well or are they missing?

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)
Comment 3 tim 2015-12-29 20:04:59 UTC
(In reply to Beluga from comment #2)
> I don't know, how to run help for languages I don't have installed.
> 
> I installed the en-GB help and the folder contains all the sbasic files cfg,
> db, ht, jar, key, tree.
> Does it contain them for you as well or are they missing?
> 
> Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
> Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
> Locale: fi-FI (fi_FI)
I'm sorry, but I don't understand your reply, since I don't know the internals of the Help system and I have no idea what 'sbasic' is.

What I have found is that the Basic (programming language) Help is missing. So I have Help for Writer, Base, Impress, Calc and so on, but not for the Basic programming language.  

Since I write quite a few Basic Macros I need the Help for the functions and so on.
Comment 4 tim 2015-12-31 13:49:25 UTC
(In reply to Beluga from comment #2)
> I don't know, how to run help for languages I don't have installed.
> 
> I installed the en-GB help and the folder contains all the sbasic files cfg,
> db, ht, jar, key, tree.
> Does it contain them for you as well or are they missing?
> 
> Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
> Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
> Locale: fi-FI (fi_FI)

I've done a bit more research to try to find out what was meant by 'sbasic' and so on.  

I have found the files. Without knowing what all they, they all seem present and correct (ie the same set as for other parts of the Help system and as the ones you listed), but the Help drop-down menu in Libreoffice stubbornly refuses to show the line for Basic.
Comment 5 tim 2016-01-06 17:25:22 UTC
Has anyone else tested this? One needs to go to the Help and look at the drop-down.  "Basic" is missing on ubuntu and windows.
Comment 6 Maxim Monastirsky 2016-01-06 19:31:29 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 96855 ***
Comment 7 tim 2016-01-06 20:22:16 UTC
Thanks (even if I reported it first :) ).

Unfortunately I can't the fix because other issues are preventing me from moving beyond 5.0.3.2 at present.