Bug 96752 - Ctrl + , for copy from above in German locale [Excel compatibility]
Summary: Ctrl + , for copy from above in German locale [Excel compatibility]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2015-12-29 03:55 UTC by Dennis Roczek
Modified: 2017-05-08 21:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2015-12-29 03:55:18 UTC
In German's Excel Ctrl + , (on a German keyboard this is easy accessible on German's keyboard) is used for copy from the cell above (same as in the German LibO Calc Ctrl + D)

Sadly i cannot change Ctrl+D to Ctrl+,

I do not want to remember multiple shortcuts for both applications but I cannot change easily Excel's ones so I do want to change Calc's shortcuts...

LibO 5.0.4.X Release
Comment 1 Cor Nouws 2015-12-29 16:53:31 UTC
Hi Dennis,

Could it be that Ctrl+, is the German setting for what is Ctrl+D in (many, I guess) other locales?
Ciao - Cor
Comment 2 GerardF 2015-12-29 17:14:20 UTC
AFAIK Excel use Ctrl+D for copy from cell above. (Unless it is different in German version of Excel)

Are you sure you are not confusing with Ctrl+'
this shortcut copy content of cell above *when the cell is in Edit mode*
in Excel and in LibO since 4.3 :
https://wiki.documentfoundation.org/ReleaseNotes/4.3#Start_cell_edit_with_content_of_cell_above
Comment 3 Dennis Roczek 2015-12-29 20:40:52 UTC
In German Version of MSO2013 Excel it is Ctrl + ,

My problem is that I cannot assign this shortcut to LibO

Dunno what Crtl+' should be as this would be on a german keyboard Ctrl+shift+# and it does not work.

@GerardF Thas shortcut (by default) does not work in German's locale and thus would be need a reassigned --> I never used that... (comment on the german release notes wiki page
Comment 4 Cor Nouws 2015-12-29 22:56:50 UTC
Hi Dennis,

a. As you can see in issue 96142, there is the possibility to change a
   short cut per language

b. Indeed, Ctrl+, is not available in the interface Tools > Customize .. Keyboard
Comment 5 Dennis Roczek 2015-12-30 00:18:31 UTC
well this ticket is only about part b) 

Part a) doesn't interest me here as I do want to have some well used (by me) known shortcuts with excel...
Comment 6 Cor Nouws 2015-12-30 07:36:12 UTC
(In reply to Dennis Roczek from comment #5)

> Part a) doesn't interest me here as I do want to have some well used (by me)
> known shortcuts with excel...

Unless Ctrl+D is not existing in German Excel, because Ctrl+, is common there?

(sorry for all the questions - we're almost there to set the proper summary, context etc usw :) )
Comment 7 GerardF 2015-12-30 09:14:28 UTC
I don't speak/read any single word in German but I googleled shortcut for Excel-de and get :
"STRG+D

Verwendet den Befehl Unten ausfüllen, um den Inhalt und das Format der obersten Zelle eines markierten Bereichs in die darunter liegenden Zellen zu kopieren."

at https://support.office.com/de-de/article/Tastenkombinationen-und-Funktionstasten-in-Excel-1798d9d5-842a-42b8-9c99-9b7213f0040f
Comment 8 Dennis Roczek 2015-12-30 13:28:46 UTC
(In reply to Cor Nouws from comment #6)
> (sorry for all the questions - we're almost there to set the proper summary,
> context etc usw :) )
No problem. That's totally OK.


(In reply to GerardF from comment #7)
> I don't speak/read any single word in German but I googleled shortcut for
> Excel-de and get :
> "STRG+D
> 
> Verwendet den Befehl Unten ausfüllen, um den Inhalt und das Format der
> obersten Zelle eines markierten Bereichs in die darunter liegenden Zellen zu
> kopieren."
> 
> at
> https://support.office.com/de-de/article/Tastenkombinationen-und-
> Funktionstasten-in-Excel-1798d9d5-842a-42b8-9c99-9b7213f0040f
Microsoft mostly translates it's own articles without any verification. Strg+D doesn't work in German locale. :-( (does nothing)

ctrl+shift+, copies stuff from above including formatting
ctrl+, copies formula / content from above

strg+d does nothing in excel. 
There are enough links from independent providers e.g. http://www.bfw-dueren.de/bildungundqualifizierung/edv-beratungundweiterbildung/ntzlichedateienfrdiearbeitampc/tastenkombinationen/excel_tastenkombinationen.pdf (containing only strg+shift+komma)
Comment 9 Cor Nouws 2015-12-30 15:14:23 UTC
All clear now :)
Should be changed in German locale.
Comment 10 Yousuf Philips (jay) (retired) 2016-03-01 20:23:22 UTC
I sent in a patch for bug 88027 which hopefully will get Ctrl + Comma into the keyboard customization list and once that patch is in, this is a 1-line fix to solve this.

If you have any other problematic shortcuts in your locale, please add them to the 'Locale' sheet of the following spreadsheet.

https://docs.google.com/spreadsheets/d/1AmDXLkQiFK5OcOrtuGn7iAcqp2Yhc_eNNnlADk-ji-U/edit?usp=sharing
Comment 11 Harald Koester 2017-05-08 20:49:23 UTC
Checked with versions 5.1.2, 5.1.3, 5.2.0 and 5.3.2: The shortcut Ctrl+; is available in the Customize dialogue beginning with version 5.1.3. Hence WORKSFORME now.
Comment 12 Dennis Roczek 2017-05-08 21:38:30 UTC
Hi Harald,

you're right. Thanks for checking. :-)

Dennis