Download it now!
Bug 96806 - In RTL cells, weak characters directionality is decided by first letter, not cell directionality
Summary: In RTL cells, weak characters directionality is decided by first letter, not ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2015-12-29 16:04 UTC by Lior Kaplan
Modified: 2018-09-30 15:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example doc (9.47 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-29 16:04 UTC, Lior Kaplan
Details
Screnshot (Win7) (1.38 KB, image/png)
2015-12-29 18:35 UTC, Urmas
Details
testdoc for 96806 (11.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-10-12 14:01 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2015-12-29 16:04:27 UTC
Created attachment 121615 [details]
example doc

When pasting the text "t בדיקה." in a Calc cell and setting the directionality to RTL the full stop at the end of the sentence appears in the middle of it. Removing the first letter (t - a strong LTR directionality) fixes the issue.

Verified in 4.4 and 5.0 branches.
Comment 1 Urmas 2015-12-29 18:23:54 UTC
That's strange, I can see ".XXXX t" in your document both in 4.4 and 5.2.
Comment 2 Urmas 2015-12-29 18:35:18 UTC
Created attachment 121616 [details]
Screnshot (Win7)
Comment 3 Lior Kaplan 2015-12-30 11:22:38 UTC
I could get confirmation for the bug on Linux from several people. Due to comment #1 I've marked the bug as Linux only.

So far, broken in 4.2, 4.3, 4.4 and 5.0. Seems to work on 4.0.

This might help to locate the regression: https://wiki.documentfoundation.org/RTL_Bugs#4.1.0
Comment 4 QA Administrators 2017-01-03 19:55:32 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2017-06-08 09:03:48 UTC
You can't confirm your own bugs.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 Lior Kaplan 2017-10-12 14:01:00 UTC
Created attachment 136924 [details]
testdoc for 96806

Still reproducible with LibO 5.4.1. The text behaves similar to Bug #113063 and bug #103495.
Comment 7 Xisco Faulí 2017-10-14 09:29:19 UTC
Hi Lior,
Could you please try to reproduce it with a master build from
http://dev-builds.libreoffice.org/daily/master/ as well?

OTOH, is it also reproduced in version of LibreOffice 3.3 (oldest one) from
http://downloadarchive.documentfoundation.org/libreoffice/old/ ?
Comment 8 Omer Zak 2017-11-11 16:47:37 UTC
Still happens in:

Version: 6.0.0.0.alpha1+
Build ID: 5d12237d79f289a1dcf8e07aa03df329e136f078
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
Comment 9 Mark Hung 2018-03-03 05:35:48 UTC
Please check with latest master build. Possibly fixed with the following commit:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e85aa0cc8b306c2f5ca6240b99e1704f772dbebb

tdf#60533 invoke ubidi_setPara with correct paraLevel parameter.

It will be available in 6.1.0.
Comment 10 Mark Hung 2018-04-28 13:02:04 UTC
Verified in 
Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group