Download it now!
Bug 96829 - CJK Ext-B characters with font PMingLiU-ExtB rendered wrongly, as empty boxes, overdrawn, or not at all
Summary: CJK Ext-B characters with font PMingLiU-ExtB rendered wrongly, as empty boxes...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2015-12-30 14:42 UTC by Mark Hung
Modified: 2016-10-02 12:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with few CJK Ext-B characters (8.92 KB, application/vnd.oasis.opendocument.text)
2015-12-30 14:42 UTC, Mark Hung
Details
Screenshot (55.01 KB, image/png)
2015-12-30 14:43 UTC, Mark Hung
Details
LibreOffice 4.4.2 v.s 5.0.4 (64.01 KB, image/png)
2016-01-05 14:34 UTC, Mark Hung
Details
printscreen from 5.2 (37.31 KB, image/png)
2016-01-07 14:33 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2015-12-30 14:42:09 UTC
Created attachment 121639 [details]
Sample document with few CJK Ext-B characters

While CJK Ext-B characters in the sample file crowd together, it works fine in 4.4.
Comment 1 Mark Hung 2015-12-30 14:43:37 UTC
Created attachment 121640 [details]
Screenshot
Comment 2 Buovjaga 2016-01-04 09:54:04 UTC
For me, it overlaps a bit differently in 4.3.
In 5.2, I don't see the ext-b character at all.

Duplicate of bug 96457?

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: b4082bed2de12cd576a06a9f456a71101809f3ed
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-01-02_00:47:38
Locale: fi-FI (fi_FI)

4.3.0.1

Set to NEEDINFO.
Change to NEW, if you don't see this as a duplicate. Change to RESOLVED DUPLICATE of bug 96457, if you do.
Comment 3 Mark Hung 2016-01-05 14:34:31 UTC
Created attachment 121731 [details]
LibreOffice 4.4.2 v.s 5.0.4

Hi Beluga,

TDF#96457 seems more like a META bug. It states Writer doesn't handle CJK EXTB characters very well in general. Issues includes
a) pasted text not rendered as rectangle
b) inconsistent behavior after reopen (docx, doc ).
c) have problem exporting pdf 
d) unable to handle 5-digit non-BMP unicode character in HTML file ( tdf#81129)

This issue focused on formatting, particular on overlapping issue. And I find there seems no such a problem in 4.4. Can we have a regression on this?
 I'm not an expert on issue classification, but I felt it is more clear that this issue stay dedicated.

Formatting problem is more related to VCL, but there are some other things to do to solve tdf#96457. If user copy-paste text from a browser, tdf#81129 has to be fixed first. For plain text, user might expect that extb font been selected when pasting those characters in plain text format as MS WORD does though not stated explicitly.
Comment 4 raal 2016-01-07 14:33:10 UTC
Created attachment 121781 [details]
printscreen from 5.2

Hello,
when I open your file I see only 6 characters -  is it correct? In your screenshot is more characters..
Comment 5 Mark Hung 2016-01-07 14:39:01 UTC
No. There are 10 characters.
First 6 use MingLiU font, the others use MingLiU-EXTB font.
Comment 6 Michael Stahl (CIB) 2016-06-07 15:43:52 UTC
apparently windows specific problem - i copied the mingliu*.ttc into ~/.fonts on Linux and the bugdoc looks fine on anything from 4.4 to master

Windows master does look broken, first 6 characters work but then 3 of the 4 last ones are rendered as empty boxes

this could probably benefit from some bibisecting...
Comment 7 Michael Stahl (CIB) 2016-09-30 13:41:41 UTC
this is not a dataLoss bug, just a rendering problem (platform-specific even)
Comment 8 Mark Hung 2016-10-02 12:46:08 UTC
This isn't reproducible in 5.2.1.2 ( Windows10, traditional Chinese)

Version:5.2.1.2
Build ID:31dd62db80d4e60af04904455ec9c9219178d620
CPU Thread:8; OS 版本:Windows 6.2; 
Locale:en-US (en_US); Calc: single

I guess that this issue has been solved after reintroducing WinSimpleLayout in 5.1.