Bug Hunting Session
Bug 96912 - Newline in Cell (ctrl+enter) ignored by Excel if formatted content of the next line pasted in Libre Office
Summary: Newline in Cell (ctrl+enter) ignored by Excel if formatted content of the nex...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: regression
: 99892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-05 19:00 UTC by alex
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2016-01-05 19:00:11 UTC
Creating a Spreadsheet Excel 2010.
Entering text "abc" in A1. Entering text "123" in B1. Entering text "456" in C1.
Closing and saving the document in XLSX. Opening the Document with Libre Office.
Double-clicking C1, selecting all text, copying it. Double clicking B1. Set cursor at end of text. Using ctrl+enter, pasting text. Pressing enter to leave cell. Confirming that there are two lines in the 'Input line'. Saving the document.
Opening the document in Excel 2010. Confirming in the 'Formular Bar' that there is only one line. 
Happens also if not pasted into the cell but into the 'Input line'.
Comment 1 raal 2016-01-09 13:19:34 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: c1258abe50f1508ea0f628ff963bc1914ab86b67
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-01-02_01:43:32


works correct in Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3 -> regression
Comment 2 Commit Notification 2016-01-27 20:31:17 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8aa853b2365430558693a32aa23825e199543cf9

we need the space="preserve" also for formatted strings, tdf#96912

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-01-27 20:31:21 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c61179b747e6309b9693cc1e2e79b2589aa807d

add test for tdf#96912

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Katarina Behrens (CIB) 2016-05-28 12:15:18 UTC
*** Bug 99892 has been marked as a duplicate of this bug. ***
Comment 5 vlb 2016-05-28 12:42:44 UTC
Is the solving also introduce in LO 5.1.4?
Comment 6 Commit Notification 2016-05-31 15:45:44 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bc1fbf9bd866091ed9b7c1f63879bfd264abf4e1&h=libreoffice-5-1

we need the space="preserve" also for formatted strings, tdf#96912

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.