Download it now!
Bug 96949 - dung out dead code...
Summary: dung out dead code...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 ToBeReviewed
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
: 96950 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-07 17:47 UTC by Michael Meeks
Modified: 2017-02-14 08:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-01-07 17:47:53 UTC
git grep m_bPreferrFirstInterceptor

seems to show a global static variable that is always true. It'd be great to cut that out along with the code paths where it would have been false - apparently they're not used =)
Comment 1 Michael Meeks 2016-01-07 17:48:30 UTC
sanity-check appreciated =)
Comment 2 Michael Meeks 2016-01-07 17:52:36 UTC
*** Bug 96950 has been marked as a duplicate of this bug. ***
Comment 3 Michael Meeks 2016-01-07 17:53:25 UTC
Also would be good to kill:

#define FORCE_DESTRUCTION_OF_INTERCEPTION_CHAIN

and conditionally include those ifdefs.
Comment 4 Stephan Bergmann 2016-01-08 07:22:55 UTC
(In reply to Michael Meeks from comment #1)
> sanity-check appreciated =)

yes, looks like m_bPreferrFirstInterceptor
 was dead-on-arrival ever since its introduction in 648106f879fdf6609db1e0d4c8acb43b3a997833, f12bd2305aaadb6a5ccb8249c80b7865e4613005 "INTEGRATION: CWS fwk01: #107642# change order of used interception objects," and FORCE_DESTRUCTION_OF_INTERCEPTION_CHAIN was dead-on-arrival ever since its introduction in 96dcdde3aa9ada7f8edfd11f4ad5cd47f22c8436 "INTEGRATION: CWS mbapp3: #i64598# destruct interception chain explicitly"
Comment 5 Commit Notification 2016-01-16 17:57:43 UTC
shubhamtibra committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d4f1f6f630d4382679087a4fb0da364c9c9692b

tdf#96949 Remove global static variable m_bPreferrFirstInterceptor and unused code

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Chris Sherlock 2016-02-14 07:51:14 UTC
Readded whiteboard keyword "target:5.2.0"
Comment 7 Robinson Tryon (qubit) 2016-02-18 14:51:24 UTC Comment hidden (obsolete)
Comment 8 jani 2016-05-02 06:41:20 UTC
Seems solved