Bug 96961 - Hide whitespace mode: whitespace is hidden even on the last page
Summary: Hide whitespace mode: whitespace is hidden even on the last page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.2.0 target:5.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-08 15:39 UTC by Miklos Vajna
Modified: 2016-10-25 19:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How it looks like currently (3.15 KB, image/png)
2016-01-08 15:56 UTC, Miklos Vajna
Details
How it should look like, I guess. (3.64 KB, image/png)
2016-01-08 15:57 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2016-01-08 15:39:13 UTC
Steps to reproduce:

1) Start writer
2) Insert a page break, so the document is of 2 pages.
3) Enable View -> Hide Whitespace

Expected: the height of the first page shrinks, but much of the whitespace on the second page remains, as in Word.

Actual: the height of both pages shrink.
Comment 1 Miklos Vajna 2016-01-08 15:56:38 UTC
Created attachment 121795 [details]
How it looks like currently
Comment 2 Miklos Vajna 2016-01-08 15:57:10 UTC
Created attachment 121796 [details]
How it should look like, I guess.

It's actually how it looks like in Word.
Comment 3 Commit Notification 2016-01-08 16:29:17 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49b67cdc36b599f865d4a6de214d901861f27196

tdf#96961 sw Hide Whitespace: still show whitespace on the last page

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-02-05 10:49:48 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f14577899781a040fa7d505f8a7554b6266aeb0c&h=libreoffice-5-1

tdf#96961 sw Hide Whitespace: still show whitespace on the last page

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.