Bug 97037 - Rendering of particular Word document with table, frames and backgound graphics completely broken, missing text etc
Summary: Rendering of particular Word document with table, frames and backgound graphi...
Status: RESOLVED DUPLICATE of bug 80635
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2016-01-11 10:58 UTC by Adrien
Modified: 2020-03-30 11:02 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Main document (43.00 KB, application/msword)
2016-01-11 10:58 UTC, Adrien
Details
Rendering of main document in MS Word 2010 (44.68 KB, image/png)
2016-01-11 10:59 UTC, Adrien
Details
correct rendering in 3.6.6. and 4.0.6 (86.49 KB, image/png)
2016-01-11 12:07 UTC, Cor Nouws
Details
partly wrong rendering in 4.1.5 (83.98 KB, image/png)
2016-01-11 12:08 UTC, Cor Nouws
Details
completely broken rendering in 5.1 / recent daily (37.29 KB, image/png)
2016-01-11 12:09 UTC, Cor Nouws
Details
sample2 (580.00 KB, application/msword)
2016-11-19 11:23 UTC, Xisco Faulí
Details
sample3 (61.00 KB, application/msword)
2016-12-01 21:42 UTC, Xisco Faulí
Details
sample4 (503.50 KB, application/msword)
2016-12-01 22:37 UTC, Xisco Faulí
Details
Main document saved as .docx (26.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-09 19:24 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien 2016-01-11 10:58:49 UTC
Created attachment 121850 [details]
Main document

I have a document that displayed correctly in MS Word.

In LibreOffice, only the title is displayed. All remaining text is missing.

I've attached also the rendering by MS Word 2010.
Comment 1 Adrien 2016-01-11 10:59:16 UTC
Created attachment 121851 [details]
Rendering of main document in MS Word 2010
Comment 2 Cor Nouws 2016-01-11 12:06:40 UTC
Thanks for filing, Adrien,

I confirm the problem.
It was ~fine in LibreOffice 3.6.6 and 4.0.6
It is half broken in 4.1.5 and fully broken in later versions.

Ciao - Cor
Comment 3 Cor Nouws 2016-01-11 12:07:40 UTC
Created attachment 121856 [details]
correct rendering in 3.6.6. and 4.0.6
Comment 4 Cor Nouws 2016-01-11 12:08:11 UTC
Created attachment 121857 [details]
partly wrong rendering in 4.1.5
Comment 5 Cor Nouws 2016-01-11 12:09:35 UTC
Created attachment 121859 [details]
completely broken rendering in 5.1 / recent daily

When opening in daily / 5.1.0rc1, the cursor starts blinking in the space between the two pages.
Comment 6 Timur 2016-01-11 17:53:40 UTC
I guess it's about Bug 78756. But, when you set Wrap to None, document already changes, image is displaced. Maybe also related to Bug 94955. So, usual suspects.
Comment 7 Joel Madero 2016-01-16 16:32:26 UTC
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Good -> Slightly Off Bibisect

b827dce34450091ab3fd608fcb1774899cb2f865 is the first bad commit
commit b827dce34450091ab3fd608fcb1774899cb2f865
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 05:16:54 2013 +0000

    source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
    
    commit 1472b5f87314fe660ef1a7b254e51272669f12f6
    Author:     Alia Almusaireae <almusaireae@kacst.edu.sa>
    AuthorDate: Mon May 6 09:11:30 2013 +0300
    Commit:     Bosdonnat Cedric <cedric.bosdonnat@free.fr>
    CommitDate: Mon May 13 15:12:01 2013 +0000
    
        zoomandviewlayout.ui widget
    
        Change-Id: I8d607a5960ffc3c69ffa97ca3e2ebae555044581
        Reviewed-on: https://gerrit.libreoffice.org/3794
        Reviewed-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>
        Tested-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>

:100644 100644 b3d561c5462e2082e8239a025b32f49179640532 3054ac942c5d4b65fec372169cf9a5cf3c8b1f32 M	autogen.log
:100644 100644 6128b74db3cb1f6c27b1a45c50f7c153ff97a258 e407fbaabbe6f6ff899f60b6c361ac957a64c045 M	ccache.log
:100644 100644 edebfbdcc3e04b63975a647dc7c0b96c150fbbd0 a9ad80935f7065b3323e9f96d191a888839923ef M	commitmsg
:100644 100644 809776d76c5acff63ae05acc840151ed3d6c838f 9d4891958550c345355ce51538d22d0bf9417611 M	dev-install.log
:100644 100644 6568832225733800f0f023ebbe299e1af2ffa2d7 9066bd3d8d2d22fa93737a7c071da2c6ef04d83a M	make.log
:040000 040000 2f51c32806a14b911a2cd80cfe103e8d9b000711 d881f8f7d4858f58d394c03c09f66a630c11dd57 M	opt


b827dce34450091ab3fd608fcb1774899cb2f865 is the first bad commit
commit b827dce34450091ab3fd608fcb1774899cb2f865
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 05:16:54 2013 +0000

    source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
    
    commit 1472b5f87314fe660ef1a7b254e51272669f12f6
    Author:     Alia Almusaireae <almusaireae@kacst.edu.sa>
    AuthorDate: Mon May 6 09:11:30 2013 +0300
    Commit:     Bosdonnat Cedric <cedric.bosdonnat@free.fr>
    CommitDate: Mon May 13 15:12:01 2013 +0000
    
        zoomandviewlayout.ui widget
    
        Change-Id: I8d607a5960ffc3c69ffa97ca3e2ebae555044581
        Reviewed-on: https://gerrit.libreoffice.org/3794
        Reviewed-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>
        Tested-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>

:100644 100644 b3d561c5462e2082e8239a025b32f49179640532 3054ac942c5d4b65fec372169cf9a5cf3c8b1f32 M	autogen.log
:100644 100644 6128b74db3cb1f6c27b1a45c50f7c153ff97a258 e407fbaabbe6f6ff899f60b6c361ac957a64c045 M	ccache.log
:100644 100644 edebfbdcc3e04b63975a647dc7c0b96c150fbbd0 a9ad80935f7065b3323e9f96d191a888839923ef M	commitmsg
:100644 100644 809776d76c5acff63ae05acc840151ed3d6c838f 9d4891958550c345355ce51538d22d0bf9417611 M	dev-install.log
:100644 100644 6568832225733800f0f023ebbe299e1af2ffa2d7 9066bd3d8d2d22fa93737a7c071da2c6ef04d83a M	make.log
:040000 040000 2f51c32806a14b911a2cd80cfe103e8d9b000711 d881f8f7d4858f58d394c03c09f66a630c11dd57 M	opt
joel@joel-Studio-1737:~/Documents/Work/Non-Profit/Libre-Office/bibisect/bibisect35$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect good 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [8ad82bc1416a07501651e8d96fe268e47d3931d3] source-hash-13821254f88d2c5488fba9fe6393dcf4ae810db4
git bisect good 8ad82bc1416a07501651e8d96fe268e47d3931d3
# good: [d084d250b04446535ca1d7c29cf2062e6bd042b3] source-hash-688f72e3a2c3ef923389bbd21f6aea3afe1114db
git bisect good d084d250b04446535ca1d7c29cf2062e6bd042b3
# bad: [c2069a369d738078124812312d51f21ea1ce2421] source-hash-f160e4935c474a5293b3d3c11b3d538efb4767a0
git bisect bad c2069a369d738078124812312d51f21ea1ce2421
# good: [e2a9149a7723f4e00eb3cafe466e204e5da19e9c] source-hash-2ede6c95e6481c92cc199e7d74fd36c841636304
git bisect good e2a9149a7723f4e00eb3cafe466e204e5da19e9c
# bad: [8901dd09508607642af790dafbbe2d9e9bb9b2a8] source-hash-be1833cbc497080af531a207f216a4f560c0b9e9
git bisect bad 8901dd09508607642af790dafbbe2d9e9bb9b2a8
# bad: [38e06ae137e1dcaaaf82127b977869499742bd94] source-hash-3fb33e3e04c7f339e1e15d24529e8ea1d4dbe321
git bisect bad 38e06ae137e1dcaaaf82127b977869499742bd94
# bad: [b827dce34450091ab3fd608fcb1774899cb2f865] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect bad b827dce34450091ab3fd608fcb1774899cb2f865
# first bad commit: [b827dce34450091ab3fd608fcb1774899cb2f865] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
# bad: [b827dce34450091ab3fd608fcb1774899cb2f865] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect bad b827dce34450091ab3fd608fcb1774899cb2f865
# first bad commit: [b827dce34450091ab3fd608fcb1774899cb2f865] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6


+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Bad -> Worse bibisect

61023f2c6c2d5a7c36b6a410b041e8aa397c59d8 is the first bad commit
commit 61023f2c6c2d5a7c36b6a410b041e8aa397c59d8
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 20:09:29 2015 +0800

    source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
    
    commit 3755c87d0426a499d4755e82d8fbc77caa240764
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Mon May 26 12:04:39 2014 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Mon May 26 12:20:47 2014 +0200
    
        bnc#863018 WW8 import: fix upper margin of multi-page floating table
    
        A vert orient position was already handled in case a floating table was
        imported as a TextFrame, but in case we didn't do that, the vert orient
        position was simply lost.
    
        Fix this by importing it as the upper margin of the table (assuming that
        the position is relative from the anchor position).
    
        Change-Id: I3e96f3068605fd6313dfb3e55483e1bce6c063a5

:040000 040000 9ec9ec8666008daa3a9dace7c3fff4006ab86d58 27c0461e0ea1c6bc9ed7ce8c95a592f235439a87 M	opt

# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'latest' 'oldest'
# bad: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect bad 8cf60cc706948588e2f33a6d98b7c55d454e362a
# bad: [d9885f526fc7a09cc8f9f8ee643af1b966be24bb] source-hash-d1465c64c6f64ad8dd25e40cdc69649b24b305ea
git bisect bad d9885f526fc7a09cc8f9f8ee643af1b966be24bb
# bad: [e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a] source-hash-dc9cc46f3223aff3f85d3ce9696178a5f4d3d087
git bisect bad e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a
# bad: [abcc1a4b07f3ef8bfeeed62b1902d8ba927e21d6] source-hash-aa48af57531851a16204381854f1ee19ebb63a6a
git bisect bad abcc1a4b07f3ef8bfeeed62b1902d8ba927e21d6
# good: [d993382687e6c349bb91f9e023bb323ad6601a19] source-hash-2448ed63610dffa54d4ec988628a3f7e29a3ecf4
git bisect good d993382687e6c349bb91f9e023bb323ad6601a19
# good: [37b67dba760dff2566d7d6d81c6e60c559ba9124] source-hash-83f760d566d61a563025ec0ca38a2f9793e0d211
git bisect good 37b67dba760dff2566d7d6d81c6e60c559ba9124
# bad: [13073f467d446b70956905b9bca85a387daca928] source-hash-25cea66f6ac06897379b6d98fdf2e443e1d3e001
git bisect bad 13073f467d446b70956905b9bca85a387daca928
# skip: [778d2210f57c434c625aa50eadfc35c32ab4277a] source-hash-3381dfec2c7e601ecd3d71725ecba184bd5b7cae
git bisect skip 778d2210f57c434c625aa50eadfc35c32ab4277a
# bad: [c1de159ea531884197b335b1738f1432631b19f6] source-hash-318ffa88240f55adef906df673614123d19f35a3
git bisect bad c1de159ea531884197b335b1738f1432631b19f6
# bad: [e27c95edf42cd783c077e5ffcf5e3d9faedf5492] source-hash-d8f958a201a8c6320684ad2e03fd15dfba818520
git bisect bad e27c95edf42cd783c077e5ffcf5e3d9faedf5492
# good: [972e54d85285a4bbcabc9bf5420fb896e0d38a29] source-hash-5b2aaefb896dfe50d9cd1551ef46cacaddcf92b7
git bisect good 972e54d85285a4bbcabc9bf5420fb896e0d38a29
# good: [bec60ae374ca7e88c85ac49500338403815380fc] source-hash-a84173738175a07429278b9010f1fbcf70aac74c
git bisect good bec60ae374ca7e88c85ac49500338403815380fc
# bad: [61023f2c6c2d5a7c36b6a410b041e8aa397c59d8] source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
git bisect bad 61023f2c6c2d5a7c36b6a410b041e8aa397c59d8
# good: [347df710b3e03def48c7c89577e25bda0afb8ef7] source-hash-09c0a96eb3ea8d48e99ed50ae7d13d23f70a0c6c
git bisect good 347df710b3e03def48c7c89577e25bda0afb8ef7
# first bad commit: [61023f2c6c2d5a7c36b6a410b041e8aa397c59d8] source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
Comment 8 Aron Budea 2016-08-15 00:11:39 UTC
For starters, adding Miklos to CC based on bibisect results.
Comment 9 Xisco Faulí 2016-10-05 18:08:34 UTC
Adding Cc: to Miklos Vajna
Comment 10 Xisco Faulí 2016-10-05 18:14:00 UTC
The first regression was introduced in 8fe8bd6c3b5b1a539b7370f8c457fa69c061d2de, which is already reported in bug 80635
Comment 11 Xisco Faulí 2016-10-08 17:06:16 UTC
*** Bug 100676 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2016-11-19 11:23:46 UTC
Created attachment 128863 [details]
sample2

Another document affected by the same commit
Comment 13 Xisco Faulí 2016-12-01 21:42:03 UTC
Created attachment 129205 [details]
sample3

Another file affected by the same commit where the content from page 1 is shifted to page 2
Comment 14 Xisco Faulí 2016-12-01 22:37:55 UTC
Created attachment 129212 [details]
sample4

another document affected by the same commit
Comment 15 Justin L 2016-12-24 12:37:44 UTC
Bug 81263 has been fixed, which means that now the text is showing again. That matches the Description's problem statement and also fixes the following:
-attachment 129205 [details] from comment 13 (v 2.2-reduced-6p.doc)
-attachment 129212 [details] from comment 14 (Sample.doc)

(In reply to Xisco Faulí from comment #10)
> The first regression, which is already reported in bug 80635,
> was introduced in 8fe8bd6c3b5b1a539b7370f8c457fa69c061d2de
>   Related: fdo#61594 SwWW8ImplReader::StartApo: don't always start a frame.

All of these are still victims of bug 80635, so marking this as a duplicate
-attachment 121850 [details] from comment 1 / Description (Resume.doc)
-attachment 125980 [details] in comment 11 from duplicate bug 100676 (inscricao_regulamento_workshop_sabores_da_india.doc)
-attachment 128863 [details] from comment 12 (AccountInfo-Sanitized.doc)

*** This bug has been marked as a duplicate of bug 80635 ***
Comment 16 Luke 2018-11-09 19:24:34 UTC
Created attachment 146510 [details]
Main document saved as .docx

This is another case where the .docx is broken in the exact same way as the .doc. More likely a dupe of Bug 80869