Bug 97049 - The new command "intd" (=dynamic integral) has no MathML output
Summary: The new command "intd" (=dynamic integral) has no MathML output
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-11 18:47 UTC by Regina Henschel
Modified: 2016-10-23 12:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example with intd (5.74 KB, application/vnd.oasis.opendocument.formula)
2016-01-11 18:47 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-01-11 18:47:06 UTC
Created attachment 121861 [details]
example with intd

Write a formula document with content
   intd{{1 over x} dx}
or use attached document. Save as MathML. Or unzip the attached document and open the content.xml.

Notice, that the semantics element has only the "annotation" child, but no real content. Compare it with
   int{{1 over x} dx}
if you do not know, how it should look.

In ODF the MathML has to contain the complete semantics, because consumers do not need to understand the content of the annotation. So not writing any MathML content is not acceptable.

The new command has been introduced with bug #53472.
Comment 1 Buovjaga 2016-01-20 11:31:49 UTC
I could reproduce the same content.xml.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 000df1832b54ba8f48c7f1c4c1cd92b70f6402da
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-18_01:08:28
Locale: fi-FI (fi_FI)
Comment 2 Commit Notification 2016-09-20 06:49:36 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a8035bcb6cf081572d86813021bbccab265a935

tdf#97049 Export "intd" to MathML

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2016-10-23 12:34:10 UTC
Hello Takeshi,
Is this bug already fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 4 Regina Henschel 2016-10-23 12:54:58 UTC
Fixed in Version: 5.3.0.0.alpha1+
Build ID: 8a796410ec8f440b4163b15b928347c499da7a8f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-20_23:07:21
Locale: de-DE (de_DE); Calc: group