Download it now!
Bug 97130 - libreoffice crashes when opening txt files and choosing utf-8 for encoding.
Summary: libreoffice crashes when opening txt files and choosing utf-8 for encoding.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-01-14 11:48 UTC by zahra
Modified: 2016-10-10 12:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
its readme-fa.txt for libreoffice in persian language. (17.56 KB, text/plain)
2016-01-14 11:48 UTC, zahra
Details
Testing on debian 8 - could not reproduce bug (308.69 KB, application/vnd.oasis.opendocument.text)
2016-01-16 19:43 UTC, Otavio Carneiro
Details
filter options (6.86 KB, image/jpeg)
2016-01-17 06:29 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zahra 2016-01-14 11:48:19 UTC
Created attachment 121930 [details]
its readme-fa.txt for libreoffice in persian language.

i used libreoffice 4.3.0.4 and i did not open text file with it. 
when i installed libreoffice 5 beta and later versions of libreoffice and when i learned how to open txt file with writer, always i face crash. 
my system is windows xp service pack 3 and my locale is fa-ir. but i tested this problem in en-us locale also. 

i tested many txt files with writer in version 5 and above and the result was crash in all. 
its a regression from version 4.3 and maybe 4.4. 
because about version 4.4 i am not shure and i should test it and give feedback. 

steps to reproduce:
1/ open libreoffice writer. 
2/ press control o or select open in the file menu. 
3/ select type of file text choose encoding txt. 
4/ open this file readme fa.txt
5/ select utf-8 encoding and dont change its language and phont and press enter or okay. 
current result: libreoffice crash. 
libreoffice 5.0 libreoffice document recovery. 
due to an unexpected error, libreoffice crashed. 
all the files you were working in will now be saved. 
the next time libreoffice is launched, your files will be recovered automaticly. 
the following files will be recovered. readme-fa.txt 
expected behaviour: libreoffice without any crash, recognizes and opens txt utf-8 persian document like version 4.3. 
if you select persian language instead of default english after choosing utf-8, the program closes immediately without any message or feedback for me in using nvda screen reader.
Comment 1 raal 2016-01-14 12:50:55 UTC
I can open the file without problems, but in my case point 5 doesn't occurs - no dialog for select encoding. Also I have not persian enviroment, font etc. But if your version is 5.0beta, please test with actual version, https://www.libreoffice.org/download/libreoffice-fresh/
Comment 2 zahra 2016-01-14 16:46:51 UTC
hi. 
 i tested in libreoffice 5 beta 3 and in all other stable versions after that and the result was the same and only crash. 
i told that open libreoffice writer and press control o or select open in the file menu. 
then libreoffice asks about encoding, phont, language etc. 
i tested in windows xp professional service pack 3 as i mentioned and i am not shure about the newer versions of windows. 
i only use windows xp and do all my work on xp.
Comment 3 Pedro 2016-01-16 19:29:14 UTC
(In reply to raal from comment #1)
> I can open the file without problems, but in my case point 5 doesn't occurs
> - no dialog for select encoding. Also I have not persian enviroment, font
> etc. But if your version is 5.0beta, please test with actual version,
> https://www.libreoffice.org/download/libreoffice-fresh/

You must use Open File, and then choose File Type > "Text - Choose Encoding (txt)" (it is the 8th option below all the Microsoft file formats)

raal, if in that dialog you choose Character Set "Unicode (UTF-8)" and switch the font to Arial you will be able to see the Persian (Farsi) characters, as expected.

I have opened the attached file with LibreOffice 5.0.4.2 and 5.1.0.2 under Windows XP Pro x86 SP3 pt_PT without any problem.

I suspect this is another case of a corrupted User Profile.
Comment 4 Otavio Carneiro 2016-01-16 19:43:28 UTC
Created attachment 122010 [details]
Testing on debian 8 - could not reproduce bug

Could not reproduce it on Debian 8 (see screens in attached file).
Comment 5 zahra 2016-01-17 04:35:33 UTC
(In reply to Otavio Carneiro from comment #4)
> Created attachment 122010 [details]
> Testing on debian 8 - could not reproduce bug
> 
> Could not reproduce it on Debian 8 (see screens in attached file).

hi pedro. 
i realy appreciate your kindness and help and i pray for you and request gods divine blessings, mercy and grace for you. 
your suggestion solved a very big problem for me. 
as i mentioned, i did not change anything except encoding and libreoffice for me by default, opened all txt documents in Liberation Mono phont. 
by its default phont Liberation Mono i tested in versions 4.3.0.4, 4.3.7.2 and also 4.4.6.3 without any problem. 
i think in libreoffice version 5 we should be more professional and know the details even phont. 
but before version 5, only opening txt persian documents with utf-8 encoding was enough without knowing and selecting the phonts exactly. 
i think that change it to resolved fixed.
Comment 6 raal 2016-01-17 06:29:54 UTC
Created attachment 122014 [details]
filter options

I can not reproduce the crash with Liberation Mono font. Tested win7, Lo 5.0.4, 5.2. Are the filter options the same as yours?

For the test, could you rename your LibreOffice directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try? Thank you
Comment 7 zahra 2016-01-19 13:08:19 UTC
hi. 
because i am not professional user, i could not do it. 
i completely uninstall libreoffice and deleated the libreoffice folder in documents and settings, user, application data and again installed libreoffice. 
the problem was remained in liberation mono phont in version 5 and above. 
i did not test other phont and i dont know exactly which phonts are compatible with persian documents. 
but i did pedro's suggestions and was good in arial phont. 
thanks you and pedro for your help. 
i wish that you solve the problem even in liberation mono.
Comment 8 zahra 2016-01-22 09:03:54 UTC
hi again. 
today i downloaded and tested libreoffice version 5.1.0.2 without any problem with opening text persian documents with liberation mono phont. 
this problem occured only in libreoffice 5.0 and not in any version that i tested until now. 
i hope that you solve it in version 5.0 branch of libreoffice. 
god bless you all and thanks for your great work.
Comment 9 raal 2016-01-22 09:29:38 UTC
Thsnks for info. Closing with Backportrequest
Comment 10 zahra 2016-02-28 17:36:28 UTC
hi. 
i wanted to appreciate you in resolving this bug. 
this bug for me was highest critical! 
because i tested many fonts and the result was only crash with many persian txt documents. 
all family of liberation including liberation mono, Liberation Sans, Liberation Sans Narrow, and Liberation Serif which i tested, the result was only crash immediately. 
also david font family, many of dejaVu font family, Freestyle Script, Arial Black, Arial Narrow, Calibri, Cordia New, CordiaUPC, Informal Roman, all lucida font family, Miriam, Miriam Fixed, Miriam Transparent, Mistral, Narkisim and many other formats which i dont remember now.. 


 DejaVu Sans Light 
DejaVu Serif
Fixed Miriam Transparent 
Source Sans Pro ExtraLight
and also Source Sans Pro Light 
libreoffice says fatal error SEh exception. access violation. 
i tested these fonts and discovered the problems in version 5.0.3
i had a very valuable document when i want to open it in version 5.0.3 i recieve immediately crash 
this is a very valuable and important that one person gave me at university. 
and because i had not permission, for the copyright, i could not attach it hear. 
it was her university final work for her degree in i think in her pht. 
its a very high gift for me. 
every time i want to open it, 
LibreOffice 5.0

LibreOffice Document Recovery

Due to an unexpected error, LibreOffice crashed. All the files you were working on will now be saved. The next time LibreOffice is launched, your files will be recovered automatically.
The following files will be recovered: 
as i mentioned, i tested all these in version 5.0.3 and one of my relatives tested in 5.0.0.5
the result was the same and only crash! 
i am not shure about version 5.0.4. 
because many people said that it was unstable and had many crashes like previous versions in 5.0 branch. 
but when i tested 5.0.5 all the error, crashes, and these problems have gon. 
i dont know how can i appreciate you for this admireable work and how to extol libreoffice virtues. 
but only i request devine infinite grace, blessings, bounty, and mercy for you all developers, users and supporters of libreoffice.


the holy quran says: 
And when you are greeted with a greeting, greet with a better [greeting] than it or return it; surely Allah takes account of all things.