Bug 97183 - Black Toolbar Icon Background When Using Breeze Theme
Summary: Black Toolbar Icon Background When Using Breeze Theme
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Icon-Theme-Breeze
  Show dependency treegraph
Reported: 2016-01-16 14:51 UTC by thanosshadow5
Modified: 2018-07-12 11:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

Screenshot of Blacked Icons (46.67 KB, image/png)
2016-01-16 14:51 UTC, thanosshadow5

Note You need to log in before you can comment on or make changes to this bug.
Description thanosshadow5 2016-01-16 14:51:34 UTC
Created attachment 121994 [details]
Screenshot of Blacked Icons

Some icons in the toolbar of Libre Office 5 Writer appear to have a black square behind them when using the Breeze theme. This issue appears only when using Linux distributions (not happening when using libre office in windows 10) and also specifically I noticed the issue in openSuSE Leap and all Fedora spins.
Comment 1 Jean-Baptiste Faure 2016-01-17 15:34:39 UTC
Thank you for reporting.

What is the exact version of LibreOffice? You can find it in menu Help > About LibreOffice.

Is OpenGL used for all rendering (menu Tools > Options > LibreOffice > View)? If it's the case, you should try to uncheck the corresponding checkbox. Does that fix the problem?

Set status to NEEDINFO, set it back to unconfirmed once you have provided requested information.

Best regards. JBF
Comment 2 thanosshadow5 2016-01-19 10:31:43 UTC
OpenGL boxes are unchecked. Oddly, when I tried to check them, after opening again Tools > Options > LibreOffice > View, OpenGL was still unchecked. The version is and later. I updated teh information you requested.
Comment 3 thanosshadow5 2016-01-23 09:17:14 UTC
Can I add something I just found out yesterday? This issue is present in most linux distributions I have tested except Kubuntu (and probably other Ubuntu flavours - not sure about derivatives though)...
Comment 4 Buovjaga 2016-01-28 15:45:05 UTC
Please try with a newer version.
Even though you don't have OGL enabled, it looks like bug 94384

Change back to UNCONFIRMED, if the problem persists with 5.0.4 or 5.1. Change to RESOLVED DUPLICATE of bug 94384, if the problem went away.
Comment 5 thanosshadow5 2016-02-19 17:06:14 UTC
Yes I tried a newer version (5.1) in opensuse tumbleweed and the problem persists. 
However I must note that, when using openSUSE Leap 42.1 Gnome 3 edition, I installed a package named something like "libreoffice-gtk". Then opened libreoffice (5.0.4 I think) and selected the breeze icon theme and to my surprise, it worked perfectly! (as it also works in ubuntu based distributions).
In openSUSE Leap 42.1 KDE plasma 5 edition, I installed the package above but still the blacked box behind the icons was there.
I am very curious to learn why that happens...
Comment 6 Adam 2016-02-25 02:46:32 UTC
Happens to me too on OpenSuse Leap 42 with LibreOffice 5.0.4. Reinstalling the Breeze icon theme doesn't help.
Comment 7 thanosshadow5 2016-04-05 21:40:28 UTC
Is there any update for the issue? I believe it has to do with openGL and the KDE environment. Enabling openGL in the gnome shell fixes the blacked icons. Enabling openGL in KDE plasma 5 does not actually enables it (I get the "openGL: Not enabled" message below the option) even when forcing it (the second option).
Is there a fix or a manual way to enable openGL? (some command?)
Comment 8 raal 2016-04-06 09:48:41 UTC
To force the use of a certain VCL UI interface, use one of the SAL_USE_VCLPLUGIN=gen, SAL_USE_VCLPLUGIN=kde4, SAL_USE_VCLPLUGIN=gtk or SAL_USE_VCLPLUGIN=gtk3 environment variables. Please, try it.
Comment 9 thanosshadow5 2016-04-06 17:56:33 UTC
Okay, how do I do this?
Comment 10 raal 2016-04-06 18:30:35 UTC
(In reply to thanosshadow5 from comment #9)
> Okay, how do I do this?

in terminal

printenv | grep SAL
Comment 11 thanosshadow5 2016-04-06 20:12:42 UTC
I don't see any difference regarding the blacked icons and the openGL
Comment 12 prof.inf 2016-09-07 17:45:16 UTC
I can confirm that with LibreOffice, after update from Ubuntu 14.04 LTS to 16.04 LTS, the toolbar icons appear with a blacked background with the same colour than the background of the toolbar, so is not possible to difference between icons and toolbar. 
Only using Breeze Theme.
Comment 13 Buovjaga 2016-09-15 10:00:26 UTC
Let's set to NEW.
Comment 14 andreas_k 2017-08-29 15:39:16 UTC
can someone confirm this with LO 5.3 or 5.4 or master?
Comment 15 Buovjaga 2017-08-29 15:48:15 UTC
(In reply to andreas_k from comment #14)
> can someone confirm this with LO 5.3 or 5.4 or master?

Guys, can you confirm?
Comment 16 Jean-Baptiste Faure 2017-08-30 04:55:08 UTC
Not reproducible for me under Ubuntu 16.04 with:
- LO 5.4.0 from Ubuntu PPA
- LO from my own build
- master from my own build
all with Breeze icon set and GTK3 backend.
Tested with GTK2 backend and with OpenGL activated or not, still not reproducible for me.
My Ubuntu is a basic Ubuntu 16.04 64 bits : Unity with the default theme Ambiance. 

Best regards. JBF