Bug Hunting Session
Bug 97244 - Incorrect preview and printing of ratio group
Summary: Incorrect preview and printing of ratio group
Status: RESOLVED DUPLICATE of bug 97120
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 98272 98312 99771 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-19 04:42 UTC by Ryszard
Modified: 2016-07-15 17:38 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
original file, sheet 2 screen shots (66.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-19 04:42 UTC, Ryszard
Details
smaller demo document from bug 98312 (10.72 KB, application/vnd.sun.xml.calc)
2016-03-20 16:28 UTC, JoNi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryszard 2016-01-19 04:42:11 UTC
Created attachment 122071 [details]
original file, sheet 2 screen shots

Rendering on screen screen is correct, print preview and printing is incorrect - text is represented by some shapes, shapes may vary by changing printers.
Pdf rendering is correct, adding text box with one space in that area correcting rendering. The libreoffice 5.1 has same problem
Attached:
original file
screenshot of correct screen 
screenshot of print preview
Comment 1 Buovjaga 2016-01-25 12:10:28 UTC
Reproduced.

It is ok in 4.3.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 6b65a0e83c4798f117be61af91dbaebdc85e94b7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-21_03:41:08
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 2 raal 2016-01-26 11:09:08 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks

946e3a3d952ed45ff0926b767839a5d2fa7b7979 is the first bad commit
commit 946e3a3d952ed45ff0926b767839a5d2fa7b7979
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Oct 23 16:14:34 2015 -0700

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97

:040000 040000 01312231b6615ea6a935cdba9f9362d2f2317970 17c5357be64abeac0cd39706edc1efb5c014d936 M      instdir

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:03:01 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:16:14 (GMT)
commit	825b3df7f1d987021ec4a08ff8e7ed78e5772c97 (patch)
tdf#94138 fix printing of edit form fields
Comment 3 JoNi 2016-03-20 16:28:18 UTC
Created attachment 123735 [details]
smaller demo document from bug 98312

added smaller demo document of bug 98312
updated with info from bug 98272
Comment 4 JoNi 2016-03-20 16:29:26 UTC
*** Bug 98312 has been marked as a duplicate of this bug. ***
Comment 5 JoNi 2016-03-20 16:29:51 UTC
*** Bug 98272 has been marked as a duplicate of this bug. ***
Comment 6 Todd 2016-04-09 04:48:34 UTC
No symptom change in LibreOffice_5.1.2_Linux_x86-64_rpm.tar.gz
Comment 7 raal 2016-05-13 12:07:54 UTC
*** Bug 99771 has been marked as a duplicate of this bug. ***
Comment 8 David Girault 2016-06-29 13:41:02 UTC
Preview and printing (and PDF export) of checkbox is also incorrect.
I think bug 97120 is the same...

Version: 5.1.4.2
Build ID: 1:5.1.4-0ubuntu1~wily1
Threads CPU : 8; Version de l'OS :Linux 4.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8)
Comment 9 Buovjaga 2016-07-15 17:38:03 UTC

*** This bug has been marked as a duplicate of bug 97120 ***