Bug Hunting Session
Bug 97263 - Gdk-WARNING **: gdk_window_set_icon_list: icons too large (REGRESSION)
Summary: Gdk-WARNING **: gdk_window_set_icon_list: icons too large (REGRESSION)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2016-01-19 22:09 UTC by Jim Avera
Modified: 2017-06-07 13:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-01-19 22:09:13 UTC
Several Gdk warnings are -always- printed to the terminal when Libre Office starts.  Besides being confusing, they pollute the terminal screen so you have to scroll back to see previous commands, etc.

This is a REGRESSION since 5.0.2.2

Using LibreOfficeDev 5.1.1.0.0 6183ae17b58ba747b529ad8c1b70ae5fd6e27e5a

$ /lotest/5.1.1.0.0/opt/libreofficedev5.1/program/soffice 

(soffice:21923): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:21923): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
Comment 1 Jim Avera 2016-01-19 22:12:18 UTC
Forgot to mention: Running on Ubuntu 15.10 (wily) x86_64.
Downloaded LibreOffice from master daily builds.
Comment 2 Buovjaga 2016-01-26 11:27:17 UTC
Confirmed.

Yet we have a ton of other warnings and I don't think they warrant their own bug reports..

Ubuntu 15.10 64-bit 
Version: 5.2.0.0.alpha0+
Build ID: c43fdd74097cb12f69f86fd1217dd2f41ccae101
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2016-01-25_23:43:01
Locale: en-US (en_US.UTF-8)
Comment 3 Tedo Vrbanec 2016-05-16 20:31:00 UTC Comment hidden (obsolete)
Comment 4 Tedo Vrbanec 2016-05-16 20:36:27 UTC
Same here @ Debian jessie 8.4, Mate DE 1.8.1. It's not just warning: quicklanch icon in system tray is missing.

Kernel	Linux 4.5.0-0.bpo.1-amd64 (x86_64)
Comment 5 QA Administrators 2017-05-22 13:40:51 UTC Comment hidden (obsolete)
Comment 6 Jim Avera 2017-05-22 18:12:31 UTC
The messages are gone again in master.  Setting to RESOLVED/WORKSFORME

Version: 5.4.0.0.alpha0+
Build ID: 0bc1e8104719b1ed9f8271f9dde407f10fb88df0
Comment 7 bugs 2017-06-07 13:19:35 UTC
Still there in Version: 5.1.6.2 on Linux Mint 18.1

(soffice:6740): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
Comment 8 Buovjaga 2017-06-07 13:43:43 UTC
(In reply to bugs from comment #7)
> Still there in Version: 5.1.6.2 on Linux Mint 18.1
> 
> (soffice:6740): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

You're testing with a way too old version. Jim said the messages are gone in 5.4.