Download it now!
Bug 97365 - HTML Clipboard issues in Base, Calc
Summary: HTML Clipboard issues in Base, Calc
Status: RESOLVED DUPLICATE of bug 37859
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 97364
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 18:08 UTC by Urmas
Modified: 2017-06-17 17:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2016-01-25 18:08:23 UTC
+++ This bug was initially created as a clone of Bug #97364 +++

When copying records from a Base table,

In HTML format, the header has "charset=windows-1252" meta, but the data contents is in UTF-8. Please fix that error.

When pasting this into Calc,

The data are interpreted as Japanese encoding, instead of Windows-1252. As a consequence, the data cannot be fixed easily with codepage converter tools. Please insert the UTF-8 data from Base in the Windows-1252 encoding.
Comment 1 Joel Madero 2016-01-28 00:02:22 UTC
Can Bug 97364 be closed as a dupe of this one ? Is one giving a separate bug?
Comment 2 Urmas 2016-01-28 00:50:10 UTC
Those are two bugs in separate components.
Comment 3 Buovjaga 2016-01-28 19:14:18 UTC
Confirmed with http://www.nirsoft.net/utils/inside_clipboard.html

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 259c1ed201f4277d74dfd600fed8c837cbf56abc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-27_00:45:12
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2017-03-06 14:35:53 UTC Comment hidden (obsolete)
Comment 5 Julien Nabet 2017-06-09 19:29:20 UTC
See https://bugs.documentfoundation.org/show_bug.cgi?id=97364#c12

I must recognize I don't see the diff between tdf#97365 and tdf#97364 since both concern copy paste from Base to Calc.
Comment 6 Buovjaga 2017-06-17 17:58:11 UTC
Let's close as dupe of 37859 after all.

*** This bug has been marked as a duplicate of bug 37859 ***