Bug 97385 - Small Word doc with image, very slow
Summary: Small Word doc with image, very slow
Status: RESOLVED DUPLICATE of bug 60425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-27 00:06 UTC by Tim Richardson
Modified: 2016-02-09 08:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
61K Word document with an image causing very slow scroll (59.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-01-27 00:06 UTC, Tim Richardson
Details
document saved in odt (54.95 KB, application/vnd.oasis.opendocument.text)
2016-01-27 00:07 UTC, Tim Richardson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Richardson 2016-01-27 00:06:40 UTC
Created attachment 122230 [details]
61K Word document with an image causing very slow scroll

This is a performance problem. The attached Word document opens in LO but it is incredibly slow to scroll even small distances, and it one attempt, it met with constant "beachballs". This is on OS X 10.11.3 on a 2015 Macbook Pro 13" 16GB, core i7.
The performance issue is due to an image. It is not a big image (the entire document is only 61K), which is why I think this is an issue.

This is not a regression. This document is also slow in 5.0.4 on OS X and Linux.
Saving the document in odt format does not improve it.
Comment 1 Tim Richardson 2016-01-27 00:07:20 UTC
Created attachment 122231 [details]
document saved in odt

document saved in odt
Comment 2 steve 2016-01-27 01:12:03 UTC
Confirmed → NEW

Version: 5.2.0.0.alpha0+
Build ID: 31ad2d7af585e8f35a645482a92bdc37a66e64ca
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-01-25_23:36:12
Locale: de-DE (de.UTF-8)

Scrolling the docx file is really choppy.

Not sure, but this file might be just broken. Opening with MS Word 15.17 the top image does not display at all.

Maybe another QA person has more detail? Otherwise we might need some dev evaluation for this bug.
Comment 3 Joel Madero 2016-01-27 19:59:05 UTC
I've looked at the file structure of the file and it seems indeed like something is wrong - opening one of the files in firefox to check what's going on froze firefox.

I'm closing as NOTOURBUG.

@Tim - if you can reproduce this with a new file and let us know how the file was created please set back to UNCONFIRMED and we'll re-evaluate.
Comment 4 Tim Richardson 2016-01-28 23:55:25 UTC
Curious. Did you try the my second attachment, the ODT file (which was generated by LO 5.1.0.2)? It also demonstrates the performance problem.
Comment 5 Buovjaga 2016-02-09 08:53:09 UTC
Well, the cause is definitely the WMF files. Found an existing report.

*** This bug has been marked as a duplicate of bug 60425 ***