Bug 97395 - FILEOPEN: Libre Office odb crashes when try to open tables from Access MDB file
Summary: FILEOPEN: Libre Office odb crashes when try to open tables from Access MDB file
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 103213 (view as bug list)
Depends on:
Blocks: Database-MS_Access
  Show dependency treegraph
 
Reported: 2016-01-27 14:01 UTC by valentizb
Modified: 2017-10-23 08:22 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
odb file that doesn't works (2.64 KB, application/vnd.sun.xml.base)
2016-01-28 09:33 UTC, valentizb
Details
first step (65.10 KB, image/jpeg)
2016-01-28 09:38 UTC, valentizb
Details
second step (29.66 KB, image/jpeg)
2016-01-28 09:38 UTC, valentizb
Details
third step (40.45 KB, image/jpeg)
2016-01-28 09:39 UTC, valentizb
Details
fourth step (36.15 KB, image/jpeg)
2016-01-28 09:39 UTC, valentizb
Details
mdb file (8.39 MB, application/vnd.ms-access)
2016-02-29 08:12 UTC, valentizb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description valentizb 2016-01-27 14:01:05 UTC
All LibreOffice crashes when I try to open tables in odb file. I can open odb file but when I try to acces tables (clicking in the left menu on the top) all LibreOffice closes with a message about automatic recovering. When I close the dialog the automatic recovering starts.
The data base is an mdb file.
It worked until the two last versions of Libre Office I installed on Windows 7 Home Premium 64 bits: 5.0.4.2 x64 and 4.5?
It works fine with the same files on Windows XP on another computer.
Comment 1 Joel Madero 2016-01-27 18:57:37 UTC
Please attach a simple sample file. Setting to NEEDINFO - once you do set the bug to UNCONFIRMED. Thanks
Comment 2 Julien Nabet 2016-01-27 19:46:11 UTC
If odb file includes embedded HSQLDB, you must think about Java part.
If you installed LO 64 bits, you must have Java 64 bits (1.6, 1.7, 1.8, whatever)
and of course if you installed LO 32 bits, you must have Java 32 bits
Comment 3 valentizb 2016-01-28 09:33:06 UTC
Created attachment 122248 [details]
odb file that doesn't works
Comment 4 valentizb 2016-01-28 09:38:24 UTC
Created attachment 122249 [details]
first step
Comment 5 valentizb 2016-01-28 09:38:39 UTC
Created attachment 122250 [details]
second step
Comment 6 valentizb 2016-01-28 09:39:02 UTC
Created attachment 122251 [details]
third step
Comment 7 valentizb 2016-01-28 09:39:26 UTC
Created attachment 122252 [details]
fourth step
Comment 8 valentizb 2016-01-28 09:54:29 UTC
I have installed and verified x64 and x32 Java but LibreOffice crashes again.
I think the odb file doesn't includes embedded HSQLDB, because I don't know anything about HSQLDB. The data base is an mdb file.
Here you are attached the odb file that crashes and all the steps I do and the screen shots (in catalan).
Automatic translation of the screen shots:
Step2: Document Recovery for LibreOffice. Due to an unexpected error, LibreOffice has failed. All files that are saved was working. The next time you restart LibreOffice, the files will be recovered automatically.
Step3: Select "Start Recovery" to start the process in the documents listed below.
Select "Discard the data recovery" to abort attempts to recover these documents.
The "Status" column indicates whether documents can be retrieved.
It is recovering the document.
Step4: The recovery of documents is complete.
Select "Finish" to see the documents.
It is recovering the document:
State of retrieved documents:
Comment 9 Julien Nabet 2016-01-28 10:22:10 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?
Comment 10 valentizb 2016-02-05 18:02:18 UTC
Julien, thanks but doesn't works
Comment 11 Julien Nabet 2016-02-05 23:04:18 UTC
Thank you for your feedback. Since I don't have more questions, let's put it back to UNCONFIRMED.
Comment 12 raal 2016-02-09 08:03:03 UTC
Hello, tested with LO 5.2master, win7 and it crashes with your file. But I have not .mdb file available.
I see two bugs here:
 - crash when accessing mdb file (your original bug). To verify this, please attach .mdb file for testing.
 - crash when .mdb file is not available


Please attach .mdb file for testing.
Comment 13 raal 2016-02-09 08:12:02 UTC
Errors:
The connection to the data source "Diapositives_libre_office" could not be established.

SQL Status: 3024
Error code: -2147467259

Unable to find file C:\temp\DIAPOSITIVES.mdb.
Comment 14 Buovjaga 2016-02-11 13:21:26 UTC
needinfo while waiting for file.
Comment 15 valentizb 2016-02-29 08:12:33 UTC
Created attachment 123068 [details]
mdb file

Data source "Diapositives_libre_office.mdb" attached
Comment 16 Buovjaga 2016-03-02 09:39:28 UTC
Crashes.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 17 Terrence Enger 2016-07-04 16:11:56 UTC
I can display the list of tables and table contents without any
problem in win32-5.2 bibisect repo, version 2016-06-23 or source-hash
49c2b98 (2015-11-25) on Widows Vista 32-bit with MS Access 2003.
Comment 18 valentizb 2016-07-11 10:28:54 UTC
Abstract:

crashes
- in my PC with Windows 7 Home Premium 64 bits and LibreOffice 5.0.4.2 x64
- in LO 5.2master, win7 (raal), without .mdb file
- in Win 7 Pro 64-bit, Version: 5.1.0.3 (x64) (Buovjaga), with .mdb file

didn't crashes
- in my PC with Windows 7 Home Premium 64 bits and with LibreOffice <4.5

don't crashes
- in my laptop with Windows XP and LibreOffice 5.0.2.2
- in win32-5.2 bibisect repo, version 2016-06-23 or source-hash 49c2b98 (2015-11-25) on Widows Vista 32-bit with MS Access 2003 (Terrence Enger), with .mdb file

Does anyone have any idea about the solution?
Comment 19 Buovjaga 2016-07-18 10:26:20 UTC
5.1.4 still crashes, but 5.3 does not. However, 5.3 does not show me any tables. It does show the .mdb as loaded in the status bar.

Would be interesting, if original reporter tested with the latest: http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: 28ac6fdc11559b58ac62089300aa99530b0b822d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-07-18_02:54:20
Locale: fi-FI (fi_FI); Calc: CL

Win 7 Pro 64-bit, Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 20 Buovjaga 2016-07-18 12:17:17 UTC
(In reply to Buovjaga from comment #19)
> 5.1.4 still crashes, but 5.3 does not. However, 5.3 does not show me any
> tables.

I got hit by bug 100964
Comment 21 Xisco Faulí 2016-09-13 10:02:33 UTC
I guess this can be bibisected with this repository:
http://dev-downloads.libreoffice.org/bibisect/win/bibisect_win_44.tar.xz.
Adding keyword 'bibisectRequest'.
Comment 22 Alex Thurgood 2016-10-19 13:41:14 UTC
*** Bug 103213 has been marked as a duplicate of this bug. ***
Comment 23 Dirk W. 2016-10-19 14:18:47 UTC
Alex, in my view, bug 97395 is not „a duplicate“ of bug 103213 but only similar.

In bug 97395, for example, „5.1.4 still crashes, but 5.3 does not“ – it depends on version. number (within 5).

In bug 103213, x64 crushes and x32 does not – it depends on bit (within 5).
Comment 24 Dirk W. 2016-11-08 12:51:11 UTC
In another bug (103217 – „PDF export of Unicode characters does not work with hexadecimal code more than four digits“) I downloaded today both current daily build of master – „master~2016-11-08_06.11.45_LibreOfficeDev_5.3.0.0.alpha1_Win_x86.msi“ and „master~2016-11-07_13.03.37_LibreOfficeDev_5.3.0.0.alpha1_Win_x64_en-US_de_ar_ja_ru_qtz.msi“ – and installed/deinstalled them.

Result: The x64-version crushes and the x32-version does not – it depends still on bit (within 5).
Comment 25 Xisco Faulí 2017-06-19 21:47:10 UTC
i can't reproduce the crash in

Versión: 5.3.3.2
Id. de compilación: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
Subproc. CPU: 1; SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

and table are seen when clicking on 'Tables'

Closing as RESOLVED WORKSFORME
Comment 26 Dirk W. 2017-06-20 06:48:54 UTC
Xisco, it’s not recognizable which version you have used: x32 or x64?

With the 5.3.4.1(x64)-Version the bug still exists!

Status: REOPENED
Comment 27 Xisco Faulí 2017-06-20 07:14:58 UTC
(In reply to Dirk W. from comment #26)
> Xisco, it’s not recognizable which version you have used: x32 or x64?
> 
> With the 5.3.4.1(x64)-Version the bug still exists!
> 
> Status: REOPENED

I've tested it on a VM Win 7 x86. it looks it just  happening in x64 then...
Comment 28 Dirk W. 2017-06-20 07:26:58 UTC
Xisco, the „Win 7 x86“ is a 32bit-version, so your LO-version is also a 32bit-version resp. 5.3.3.2 (x32). In the 32bit-version of LO the bug doesn’t emerge since 5.0, but in all x64-versions of 5.x.x.x until today the bug still exists!
Comment 29 Xisco Faulí 2017-06-20 07:30:21 UTC
Hi Dirk,
Thanks for the clarification! The bug's hardware field was set to 'All' so I thought it was reproducible in all architectures. Updated accordingly now.
Comment 30 Buovjaga 2017-06-20 09:37:31 UTC
Now it cannot establish connection to the .mdb. "May be the necessary data provider is not installed". No such problem in my previous tests.. do I need Access now??

Win 7 Pro 64-bit Version: 6.0.0.0.alpha0+ (x64)
Build ID: a1ace08b5b86a76e7275dcef2545a7d52ae2ed2d
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-13_03:04:47
Locale: fi-FI (fi_FI); Calc: CL
Comment 31 Julien Nabet 2017-06-20 09:47:07 UTC
(In reply to Buovjaga from comment #30)
> Now it cannot establish connection to the .mdb. "May be the necessary data
> provider is not installed". No such problem in my previous tests.. do I need
> Access now??
> ...
See 
https://bugs.documentfoundation.org/show_bug.cgi?id=97579#c10
and
https://bugs.documentfoundation.org/show_bug.cgi?id=97579#c16 (I put this tracker in See also)
Comment 32 DocTom 2017-09-07 08:33:19 UTC
I have used LO Base for the last 2 years, with Debian 8 Jessie/Cinnamon OS on a 32bit laptop computer.

After upgrading to Debian 9 Stretch/Cinnamon, my databases crash as soon as I try to open Tables (Forms, etc seem to be OK.)  I cannot access the tables at all.
Comment 33 Julien Nabet 2017-09-07 08:41:22 UTC
DocTom: are your files related to mdb? If not, this bugtracker doesn't apply to your case.
Comment 34 Alex Thurgood 2017-09-07 09:33:53 UTC
(In reply to DocTom from comment #32)
> I have used LO Base for the last 2 years, with Debian 8 Jessie/Cinnamon OS
> on a 32bit laptop computer.
> 
> After upgrading to Debian 9 Stretch/Cinnamon, my databases crash as soon as
> I try to open Tables (Forms, etc seem to be OK.)  I cannot access the tables
> at all.

@DocTom : as Julian has mentioned, unless your problem relates to MDB databases, you are probably reporting in the wrong bug report.

At a guess, since you mention 32bit and update to Debian 9, you are suffering from bug 108619
Comment 35 Alex Thurgood 2017-10-20 14:00:59 UTC
LibreOffice on Windows relies on the database driver components provided by Microsoft.

Microsoft no longer provides for reading/writing to a 32bit Access db (versions created with Access 97, 2003) on its 64bit systems. There is information about this on both MSND, and Microsoft's own knowledgebase websites.

I suggest closing this, and other similar reports as either WONTFIX, or NOTOURBUG, or else WFM in 64bit everything and Access >= 2010.