Bug 97402 - Black bar over UI on fullscreen
Summary: Black bar over UI on fullscreen
Status: RESOLVED DUPLICATE of bug 76476
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 97709 108822 116187 (view as bug list)
Depends on:
Blocks: Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2016-01-27 21:11 UTC by Mazen Mardini
Modified: 2018-04-02 12:17 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Black bar on Mac OS X in Fullscreen-Mode (107.64 KB, image/png)
2016-03-19 18:14 UTC, Emilio Rezzonico
Details
Screencast black bar in fullscreen-mode (2.73 MB, video/quicktime)
2016-11-13 15:33 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mazen Mardini 2016-01-27 21:11:00 UTC
On fullscreen on Mac OS X a black bar will appear on top of the user interface that stretches across the screen. It is about 15px in height.

It is probably a space that was left there to make room for the menu bar, but as you do know, Mac OS X has the menu bar integrated into the toolbar, so it should never appear inside the program. This might be the problem that lead to the bar appearing on top of the UI like that.
Comment 1 Emilio Rezzonico 2016-03-19 18:14:50 UTC
Created attachment 123723 [details]
Black bar on Mac OS X in Fullscreen-Mode
Comment 2 Emilio Rezzonico 2016-03-19 18:17:19 UTC
Same here. I added a screenshot. The only workaround to avoid this behaviour is pressing alt+shift while clicking the green maximize-button
Comment 3 Alex Thurgood 2016-03-20 13:01:37 UTC
I don't see this on 

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)

whether I expand window via the green window button shortcut or via Shift-Cmd-J

Try upgrading your version of LibreOffice
Comment 4 Mazen Mardini 2016-03-20 13:31:59 UTC
I'm running the same build:

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 8; OS Version: -; UI Render: GL; 
Locale: sv-SE (sv.UTF-8)

Your UI renderer is different than mine.
Comment 5 Emilio Rezzonico 2016-03-22 17:59:47 UTC
Sorry forgot this detail about the screenshot:

Version: 5.1.1.3
Build-ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU-Threats: 4; BS-Version: Mac OS X 10.11.4; UI-Render: GL; 
Gebietsschema: de-DE (de.UTF-8)
Comment 6 Mazen Mardini 2016-03-22 18:03:20 UTC
(In reply to Emilio Rezzonico from comment #5)
> Sorry forgot this detail about the screenshot:
> 
> Version: 5.1.1.3
> Build-ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
> CPU-Threats: 4; BS-Version: Mac OS X 10.11.4; UI-Render: GL; 
> Gebietsschema: de-DE (de.UTF-8)

Could you please change the status to CONFIRMED.
Comment 7 ace_dent 2016-05-10 11:48:23 UTC
Tested with: Mac OS X El Capitan 10.11.4 (15E2066) with LibreOffice Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default.

It seems using the native OSX full-screen behaviour (which now puts the zoomed in window in it's own space), is broken. The central issue is how LO handles Spaces on OSX.

Workaround: Double click on the window's title bar to maximise the window (like 'full screen' in earlier OSX versions).

Related, possibly duplicated, issues ~ 
Missing menu bar: #53282, #76476, #96134, #97402, #97709.
Extra blank screen: (black- was grey) #72490, #83378, #96134.
General: #85259, #95362.
Comment 8 Julien Nabet 2016-07-03 12:03:37 UTC
3 things to test:
1) Rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X)
2) Give a try to last stable LO version 5.1.4
3) In menu LO/Preferences/View, disable both checkboxes concerning OpenGL and restart LO.
Comment 9 Telesto 2016-11-13 15:33:11 UTC
Created attachment 128728 [details]
Screencast black bar in fullscreen-mode

Made with:
Version: 5.3.0.0.alpha1+
Build ID: 0d75c63a307616b8327b1828d2ab973f4713822b
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; Layout Engine: new; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-11-12_00:32:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 10 Telesto 2016-11-14 15:25:09 UTC
*** Bug 97709 has been marked as a duplicate of this bug. ***
Comment 11 Alex Thurgood 2017-06-28 07:59:48 UTC
*** Bug 108822 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2018-03-05 08:58:22 UTC
*** Bug 116187 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2018-03-08 13:33:13 UTC
Still reproducible in

Version: 6.1.0.0.alpha0+
Build ID: dac81c4dc76e6061c9e41957b980206f2b6c730e
CPU threads: 8; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group
Comment 14 eisa01 2018-04-02 12:17:36 UTC
This is a duplicate

*** This bug has been marked as a duplicate of bug 76476 ***