Bug 97458 - LO 5.1.0.3 - Writer: Immediate crash after opening ".docx" or ".odt" when OpenGL enabled (Intel HD 3000)
Summary: LO 5.1.0.3 - Writer: Immediate crash after opening ".docx" or ".odt" when Ope...
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.1
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-01-31 00:29 UTC by Joe Fisher
Modified: 2016-10-25 19:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
output from msinfo32.exe (528.62 KB, text/plain)
2016-01-31 04:11 UTC, Joe Fisher
Details
opengl_device.log (315 bytes, text/x-log)
2016-01-31 18:30 UTC, Joe Fisher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Fisher 2016-01-31 00:29:30 UTC
LibreOffice 5.1 - Fatal Error
SEH Exception: ACCESS VIOLATION

Immediately after installing and opening a LO Writer file (.docx) or (.odt) the application crashes.
Comment 1 Joe Fisher 2016-01-31 00:31:41 UTC
LibreOffice_5.1.0.3_Win_x86.msi
LibreOffice_5.1.0.3_Win_x86_helppack_en-US.msi
Comment 2 V Stuart Foote 2016-01-31 02:03:05 UTC
@Joe Fisher,

Please clip the Help -> About details and also give use some details of your Windows OS (run msinfo32.exe)

Thanks.
Comment 3 Joe Fisher 2016-01-31 04:11:55 UTC
Created attachment 122293 [details]
output from msinfo32.exe
Comment 4 Joe Fisher 2016-01-31 04:15:56 UTC
Windows 7 Enterprise, 64 bit OS
Dell Vostro 2420
Intel i3-2328M, 16 GB RAM, 500 GB Samsung EVO 850 SSD
Comment 5 V Stuart Foote 2016-01-31 05:09:22 UTC
@Joe,

Hmm, the Intel HD 3000 GPU may be at fault. The 9.17.10.4229 driver looks reasonably current but I believe it maxes out at OpenGL 3.1 support. 

Please disable OpenGL (Tools -> Options -> View and restart) and test again.

The %APPDATA%\LibreOffice\4\cache\opengl_device.log should confirm.

Also, might post up a sample OOXML or ODF text document that is causing you issues. We'd be looking for the document content that is faulting.  Are the other modules behaving, just Writer? Or, do all modules crash?
Comment 6 Joe Fisher 2016-01-31 18:30:02 UTC
Created attachment 122300 [details]
opengl_device.log

Here's the opengl_device.log file just after I unchecked "use OpenGL" and closed LibreOffice. 

Now when I reload the (.docx) and (.odt) file the program doesn't crash. I'm not sure if there are any other problems but I'll further test Monday evening.
Comment 7 V Stuart Foote 2016-01-31 19:17:42 UTC
Suspect issue with this Intl HD 3000 GPU and driver passing the OpenGL blacklist when it should not.  Adding to bug 93529
Comment 8 Buovjaga 2016-01-31 19:50:12 UTC
I have reported this before as bug 96546

Meeks marked it as fixed, but that was only for OGL not being automatically disabled after crash.
Unfortunately the automatic disabling still doesn't work.

When I was testing this, a 5.1 with a fresh profile had correctly disabled OpenGL according to the blacklist. It appears this is not the case for Joe Fisher :(

I am sure we will hear more about the status of this from Monsieur Meeks after he returns from FOSDEM.
Comment 9 Commit Notification 2016-02-08 21:04:56 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce81a477d228277f44e96356e85d92467eb7a0b9

tdf#97458 - remove unused intel opengl driver version special-casing.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-02-09 07:51:54 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22b852788d94ecacde533e3961a3535ef2a89f7d&h=libreoffice-5-1

tdf#97458 - remove unused intel opengl driver version special-casing.

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Buovjaga 2016-02-11 08:10:13 UTC
*** Bug 97493 has been marked as a duplicate of this bug. ***
Comment 12 Michael Meeks 2016-02-11 17:56:50 UTC
Trying to collect all of these apparent black-listing failures in one-place.

*** This bug has been marked as a duplicate of bug 96546 ***